Update auf 5.1.6

Hallo,

ich habe gerade ein Backup auf die aktuelle Version 5.1.6 gemacht - was auf den ersten Blick reibungslos funktionierte.

Im Frontend erhalte ich aber keine Artikel mehr angezeigt, im Firebug erscheint folgende JS - Meldung:

TypeError: window.controller is undefined

 

Weiss da jemand Hilfe? Ansonsten konnte ich im Backend erstmal keine Schwierigkeiten feststellen, Cache habe ich geleert …

 

Vielen Dank

 

Falk

Hallo,

folgender ergänzender Eintrag in deiner config.php - Datei wird dir die Fehlermeldung anzeigen, die dir weiterhelfen wird:

'front' => array(
    'throwExceptions' => true,
),

Weitere Informationen: http://community.shopware.com/config.php-Tweaks_detail_1801.html#Debug-Configuration .

Beziehungsweise würde die Google aber auch die Forumssuche weiterhelfen, die genau zu dieser Fehlermeldung entsprechende Themen liefern: http://forum.shopware.com/discussion/30689/typeerror-window-controller-is-undefined .

Beste Grüße

Sebastian

1 Like

Ok, danke … das hat soweit geholfen… allerdings erhalte ich jetzt, nachdem es gestern ganz ordentlich aussah folgende meldung im FE:

Fatal error: Uncaught exception ‘Enlight_Controller_Exception’ with message ‘Controller “index.php” not found’ in /engine/Library/Enlight/Controller/Dispatcher/Default.php:486 Stack trace: #0 /engine/Library/Enlight/Controller/Front.php(226): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #1 /engine/Shopware/Kernel.php(153): Enlight_Controller_Front->dispatch() #2 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(492): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #3 /engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #4 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(449 in /engine/Library/Enlight/Controller/Dispatcher/Default.php on line 486

Was mir aufgefallen ist, das im /cache/ verzeichnis gar nichts drin steht … obwohl es schreibrechte hat

Was kann ich  hier noch tun?

 

Falk

Die Meldung sagt nur, dass du /index.php aufgerufen hast. Das ist nicht die richtige Fehlermeldung.