Thumbnail über Konsole neu generieren

Hi, ich wollte die Thumbnails über die ShellConsole neu generieren lassen, weil im Browser bei 1400 Bildern immer ein Fehler kommt. Ich nutze dazu den Befehl php console sw:thumbnail:generate Leider erhalte ich dann immer folgenden Fehler. Site error: the file /var/www/clients/client3/web12/web/engine/Shopware/Plugins/Community/Core/SwagLicense/Bootstrap.php requires the ionCube PHP Loader ioncube_loader_lin_5.6.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation. Grundsätzlich ist aber der ionCube PHP Loader installiert und eingerichtet. Hat dazu jemand eine Idee?

Hallo, ggf. musst du auf der Konsole speziell die Version ansteuern. Das ist je nach Hoster auch unterschiedlich. Bei deinem Aufruf fehlen so IonCube und auch evtl. wird eine alte PHP Version genutzt. Beispiel: /usr/local/php5.4/bin/php console sw:thumbnail:generate oder php54 console sw:thumbnail:generate Das nur als Beispiel. Das kann der Hoster dir sicher mit einem Beispiel genau mitteilen. Sebastian

1 Like

Ist PHP 5.6 bei Deinem Hoster schon empfohlen??? PHP5.5 sollte jedenfalls produktiv sein - 5.6 bei meinem nicht (ist allerdings 1und1) Nach meinen bisherigen Recherchen scheint das mit den Thumbnails eher ein Käfer zu sein… aber ich bin noch neu hier und habe sicherlich nicht alles dazu lesen/finden können

Vielen Dank Sebastian mit dein Vorschlägen hat es funktioniert :thumbup:

Hallo, ich stehe vor dem Problem der Thumbnail-Generierung von ca 8.000 Bildern. Natürlich bricht hier die Generierung per Medienverwaltung ab :slight_smile: Nun meine Frage: Überall lese ich war von der Generierung über die Console mit sw:thumbnail:generate aber nirgends finde ich eine Anleitung dazu, wo ich das eingebe oder wie ich dazu komme. Könnt ihr mir hier bitte weiterhelfen? Danke!

Ich schließe mich Mutoweb´s Frage an und ergänze das ganze noch durch die Frage: - Wenn man bei dem Album “Artikel” noch Unteralben erstellt hat… muss man die alle komplett neu konfigurieren (also mit den neuen Thumbnail-Größen)…

@squadhousemedia: Ok wie die Konsole funktioniert habe ich nun gefunden :slight_smile: administration-f55/shopware-konsole-t27711.html#p121280

hallo,

 

ich möchte auch gerne die Thumbnails neu erstellen.

Wenn cih folgendes eingebe: php bin/console sw:thumbnail:generate

 

erhalte ich die Meldung: Could not open input file: bin/console

Woran kann das liegen?

In der Regel passen dann die Zugriffsrechte nicht. Versuch mal “chmod +x bin/console”

Danke für die Antwort. Wenn cih das eingebe erhatle ich: 
chmod: cannot access ‘bin/console’: No such file or directory

 

 

Hab es geschafft. Ich war im falschen Verzeichnis. Danke!

Guten Tag zusammen,

ich versuche jetzt seit 2 Wochen diesen Befehl „sw:thumbnail:generate“ in der Console einzugeben, bzw. zum laufen zu bringen. Leider kann mir mein Webhoster (Ionos) auch nicht weiterhelfen. Daher hoffe ich nun hier die Lösung zu finden. 

Mein Shop befindet sich im Verzeichnis „SHOPWARE“. Daher gehe ich davon aus, dass ich auch in dieses Verzeichnis mit „cd SHOPWARE“ gehen muss. Danach habe ich diverse Befehle eingegeben wie: 

 sw:thumbnail:generate, php console sw:thumbnail:generate, php54 console sw:thumbnail:generate, usw.

Leider kein Erfolg. Ein Mitarbeiter von Ionos sagt mir, falls die PHP-Version nicht ausreichend ist, dass ich mit der Kombination „php + 2mal Tab“ eine Übersicht der Versionen sehen kann. Wie ich dann weiter vorgehen kann, weiß weder er und ich als Laie sowieso nicht.

Kann mir bitte jemand weiterhelfen? Danke vielmals!

 

Kann mir niemand weiterhelfen? Vielleicht gibt es hier 1&1 Kunden, die das schon gemacht haben und mir dann sagen können, wie es geht?

@MSBerlin‍ in mhh die console php liegt aber im “bin” verzeichnis soweit ich weiß. also:

cd SHOPWARE
php bin/console sw:thumbnail:generate

Und bezüglich der Aussage deines Hostsupports: Meiner Meinung nach hat er sich kein bisschen bemüht. Es wäre jedem Admin aufgefallen, dass es keine “console” Datei in diesem Verzeichnis gibt (~/SHOPWARE) und die Fehlermeldung deine zweiten Versuches sagt auch genau das.

1 Like

Hallo langnickel, danke für Deine Antwort. Leider gibt es weiterhin Fehlermeldungen: 

 

mach mal “php -v” dann siehst du welche Version du so in der CLI hast - wahrscheinlich eine zu alte (lt. Fehlermeldung).

Danach halt mal eine andere PHP-Versio nutzen.

1 Like

@MSBerlin schrieb:

Kann mir niemand weiterhelfen? Vielleicht gibt es hier 1&1 Kunden, die das schon gemacht haben und mir dann sagen können, wie es geht?

Hier im Forum gibt es ähnliche Beiträge wo bereits schon mehrmals darauf hingewiesen wurde, dass die PHP-Version auf der Konsole nicht zwangsläuft die PHP-Version vom Hosting ist. Das ist von Anbieter zu Anbieter recht unterschiedlich. Ob 1&1 hier auch andere PHP-Version über die Konsole zur Verfügung stellt, ist auch noch fraglich. Das müsste geprüft werden. Genrell ist aber 1&1 für Shopware eher ungeeignet. 

1 Like

Vielen Dank langnickel, Moritz und R4M!

Es funktioniert endlich *juhu*

Bin alle php-Versionen durchgegangen und auch mit dem bin vor console klappt es jetzt.

Also: php7.1 bin/console sw:thumbnail:generate

Grüße, Michael