SW 5.2: Euer Lightweight Beispiel schmeisst einen Fehler

Ext.define('Shopware.apps.Index', {
extend:'Enlight.app.SubApplication',
bulkLoad: true,
loadPath: '/backend/index/load',
controllers:[
'Main',
'Widgets',
'ErrorReporter',
'ThemeCacheWarmUp'
],
requires: [
'Shopware.container.Viewport'
],
views: [
'Main',
'Menu',
'Footer',
'Search',
'widgets.Window',
'widgets.Sales',
'widgets.Upload',
'widgets.Visitors',
'widgets.Orders',
'widgets.Notice',
'widgets.Merchant',
'widgets.News',
'widgets.Base',
'merchant.Window',
'themeCache.ThemeCacheWarmUp'
],
models: [
'Widget',
'WidgetSettings',
'Turnover',
'Batch',
'Customers',
'Visitors',
'Orders',
'News',
'Merchant',
'MerchantMail',
'ThemeCacheWarmUp'
],
stores: [
'Widget',
'WidgetSettings',
'ThemeCacheWarmUp'
]
});

Hallo,

euer Lightweight Backend Module Beispiel schmeisst einen Fehler in der neuesten SW 5.25 Version:

Gibt es daf√ľr schon eine L√∂sung?

VG

Frank

 

Hi Frank,

wie sieht der Fehler denn aus?

Gr√ľ√üe
AvL

Hey @snapdragon‚Äć,

ich habe mir die Geschichte einmal angeschaut & die CSRF-Token Fehler beim Navigieren beseitigt.

Viele Gr√ľ√üe,
Stephan Pohl  Shopware

1 Like

Falls ihr noch¬†weitere¬†Fehler findet, dann meldet euch einfach. Ich k√ľmmere mich drum.

Viele Gr√ľ√üe,
Stephan Pohl  Shopware

Hi Stephan,

in dem Package fehlt die PostMessageApi.js (der Pfad

 backend/base/frame/

existiert nicht.). Damit ist die Funktionalität des Plugins nicht testbar.

Kannste das noch nachschieben?

VG

Frank

 

Das Plugin ist testbar, einfach auch mal probieren …

Die postmessage-api.js wird aus dem Extjs Base Template geholt: /themes/Backend/ExtJs/backend/base/frame/postmessage-api.js

Hallo,

das Plugin wirft ebenfalls einen CSRF Token Fehler, wenn man versucht ein Subwindow via

 postMessageApi.createSubWindow();

zu öffnen.

Hi,

 

das Plugin schmeisst erneut einen Fehler beim √Ėffnen im Backend (Version 5.2.8):

 

Controller ‚ÄúExampleModulePlainHtml‚ÄĚ can‚Äôt load failure in engine/Shopware/Components/Plugin/Bootstrap.php on line 578

Stack trace:

 #0 engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware\_Components\_Plugin\_Bootstrap-\>getDefaultControllerPath(Object(Enlight\_Event\_EventArgs)) #1 engine/Library/Enlight/Event/EventManager.php(251): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Event\_EventArgs)) #2 engine/Library/Enlight/Controller/Dispatcher/Default.php(368): Enlight\_Event\_EventManager-\>notifyUntil('Enlight\_Control...', Array) #3 engine/Library/Enlight/Controller/Dispatcher/Default.php(447): Enlight\_Controller\_Dispatcher\_Default-\>getControllerPath(Object(Enlight\_Controller\_Request\_RequestHttp)) #4 engine/Library/Enlight/Controller/Dispatcher/Default.php(485): Enlight\_Controller\_Dispatcher\_Default-\>isDispatchable(Object(Enlight\_Controller\_Request\_RequestHttp)) #5 engine/Library/Enlight/Controller/Front.php(223): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #6 engine/Shopware/Kernel.php(177): Enlight\_Controller\_Front-\>dispatch() #7 vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #8 engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #9 vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #10 engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #11 shopware.php(113): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #12 {main}

 

Was könnte das sein?

 

VG

Julian

Guten Morgen,

hat noch niemand Erfahrungen mit den Lightweight Modulen in aktuellen Shopware Versionen (>5.2.6) ? Ich erhalte mit verschiedenen Konfigurationen in zwei verschiedenen Testshops in jedem Fall die obige Fehlermeldung! 

Viele Gr√ľ√üe

Julian Gerhard