Subshops laden Theme nicht

Hallo an Alle!

Ich hab ein Problem bzüglich der Subshops. Also eigentlich sieht alles recht gut aus, nur übernehmen diese unser Theme nicht, sondern werde im Standard responsive Design ausgegeben.

Zusätzlich scheint unser .de Shop auch nichts von den anderen zu wissen. Oben rechts, wo man die anderen Sprachen auswählen kann, sind nur unsere Sprachshops (Also die, die auf der selben Domain laufen, zb. .de/en) aber nicht die, die auf einer eigenen URL laufen. Irgendeine Verbindung scheint wohl nicht korrekt hergestellt zu sein.

Die Artikel, cms-Seiten usw werden korrekt geladen. Bei den Shop-Einstellungen sollte eignetlich auch alles stimmen…

Bin ein wenig überfragt und würde mich über Hilfe freuen :wink:

Zur Info: CE 5.2.8

LG Jack52

Hi,

bei Subshops musst du jeweils ein Theme zuweisen - das ist ja neben der Domain einer der Haupt-Unterschiede zwischen Sprach- und Subshop. Dass die Subshops im Sprachauswahlmenü nicht erscheinen ist soweit auch richtig. Du könntest den Subshops ja jeweils wieder Sprachshops zuweisen.

Ein Subshop ist (aus Frontend-Sicht) ja ein eigenständiger Shop.

Ich würde sagen, dass das Verhalten genau so gedacht ist oder ich verstehe dich falsch.

Viele Grüße

Philipp

1 Like

Ja, das scheint wohl so zu sein, dass Subshops unabhängig voneinander laufen.

Zum Problem des Theme: Das habe ich nun gelöst!. Man muss nicht nur das Theme zuordnen, sondern auch alle Änderungen der Theme-Einstellungen für jeden Subshop nochmal eintragen. Insbesondere die Verweise zu den .css Dateien. Es sah also nur so aus, als wenn das Theme nicht geladen wird. Es wurde schon geladen, nur die Verweise haben gefehlt.

Ist etwas schwierig zu durchdringen, aber macht Rückblickend schon Sinn.

Beste Grüße

Jack52

 

1 Like

Hallo,

mit der aktuellen Shopware Version 5.3.4 habe ich das selbe Problem mit dem Theme.

@ Jack24

Könntest du mir kurz sagen wo ich genau diese .css Verweise und die Theme Einstellungen vornehme?

Das Theme für den Sub Shop habe ich ausgesucht, aber die Inhalt werden nicht angzeigt. Sprich das Design fehlt.