SSL-Problem - Laden von Scrips aus nicht authentifizierten Quellen

Guten Tag liebe Shopware-Community,

ich habe gerade ein SSL-Zertifikat für Apache eingerichtet. Seitdem lässt sich ein Produkt nicht mehr zum Warenkorb hinzufügen. Wenn ich dies tuen möchte, erscheint in meinem Browser  (Google Chrom) rechts oben in der Suchleiste ein Symbol, welches besagt: “Diese Seite versucht, Skripts aus nicht authentifizierten Quellen zu laden.”. Um ein Produkt nun in den Warenkorb hinzuzufügen, muss ich auf das Symbol drücken und anschließend die Scrips laden lassen. Firefox blockiert komplett.
Wenn ich mir dem Quellcode von Shopware in PHP ansehe, stelle ich fest, dass die Scripts (AJAX, etc.) alle über “http” und nicht “https” geladen werden.

Meien Frage ist nun: Wie stelle ich um, dass die Scrips über “https”, anstelle von “http” geladen werden? - Muss ich in den Shopware-Einstellungen etwas verändern oder in einer Template-Datei, in welcher die Scrips geladen werden (Datei-Pfad…?!)?

Ich hoffe um Hilfe, da ich Shopware sonst nicht mehr benutzen kann!

Viele Grüße,
Julius

 

Hallo Julius,

in den Grundeinstellungen unter Shops muss du SSL aktivieren:
http://community.shopware.com/Wie-kann-ich-mein-SSL-Zertifikat-im-Shop-einrichten-aktivieren%3F_detail_145.html

Du kannst auch den gesamten Shop dort auf SSL umstellen. Dann empfehle ich noch folgenden Artikel:
http://community.shopware.com/Umleitung-aller-Aufrufe-auf-HTTPS-Domain_detail_1863.html

Sebastian

1 Like

Vielen Dank für die Antwort! :slight_smile:
Das Thema kann hiermit geschloßen werden.