Shopware Flex Template Installation

Hallo, ich versuche gerade das Shopware Flex Template zu installieren.

Das erhalte ich :

composer create-project shopware/production:dev-flex shopware-flex

erfolgreich

shopware-flex % bin/console system:install --basic-setup

n TransportFactory.php line 54:
                                                                                                       
  No transport supports the given Messenger DSN "doctrine://default?auto_setup=0". Run "composer requ  
  ire symfony/doctrine-messenger" to install Doctrine transport..                                      
                                                                   
symfony/doctrine-messenger

manuelle installtion hilft auch nicht


was läuft hier falsch? bitte

~Marc

Hey,

da war noch ein Fehler im Recipes Repository. Wenn du bereits ein Git repo hast, sollte ein composer recipes:update helfen.

Ansonsten kannst du auch composer recipes:install --force --reset ausführen.
Oder ein composer create-project shopware/production:dev-flex shopware-flex

1 Like

Jetzt lief der Prozess fehlerfrei.
Vielen Dank!

composer create-project shopware/production:dev-flex shopware-flex
Kann ich hier auch irgendwie bestimmmen das gleich Shopware 6.5 RC installiert wird?

[EDIT]
ich sehe gerde:

Gibt es dann auch gleich einen Modus um Webpack auch in dev modus zu starten sodas man einenen JS Code einfacher debuggen kann (Fehler direkt im eigenen code anzeigen und nict im Bundle)??

Mit composer create-project shopware/production:6.5.0.0-dev bekommst du die aktuellste RC.

3 Likes

Vielen Dank für die Antwort !
DANKE

Das gibt folgende Fehler:

composer create-project shopware/production:6.5.0.0-dev shopware-65-rc-dev
Creating a "shopware/production:6.5.0.0-dev" project at "./shopware-65-rc-dev"
Info from https://repo.packagist.org: #StandWithUkraine
Installing shopware/production (6.5.0.0-dev e433a3814e0b6be23369f9f43525491b55c1eb7e)
  - Downloading shopware/production (6.5.0.0-dev e433a38)
  - Installing shopware/production (6.5.0.0-dev e433a38): Extracting archive
Created project in /Users/daslicht/Sites/shopware-65-rc-dev
Loading composer repositories with package information
Updating dependencies
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires shopware/administration ~v6.5.0 -> satisfiable by shopware/administration[6.5.0.0-rc1].
    - shopware/administration 6.5.0.0-rc1 requires php ~8.1.0 || ~8.2.0 -> your php version (8.0.27) does not satisfy that requirement.
  Problem 2
    - Root composer.json requires shopware/core ~v6.5.0 -> satisfiable by shopware/core[6.5.0.0-rc1].
    - shopware/core 6.5.0.0-rc1 requires php ~8.1.0 || ~8.2.0 -> your php version (8.0.27) does not satisfy that requirement.
  Problem 3
    - Root composer.json requires shopware/elasticsearch ~v6.5.0 -> satisfiable by shopware/elasticsearch[6.5.0.0-rc1].
    - shopware/elasticsearch 6.5.0.0-rc1 requires php ~8.1.0 || ~8.2.0 -> your php version (8.0.27) does not satisfy that requirement.
  Problem 4
    - Root composer.json requires shopware/storefront ~v6.5.0 -> satisfiable by shopware/storefront[6.5.0.0-rc1].
    - shopware/storefront 6.5.0.0-rc1 requires php ~8.1.0 || ~8.2.0 -> your php version (8.0.27) does not satisfy that requirement.

Hallo,

laut Fehlermeldung hast Du PHP 8.0.27 laufen, benötigst aber mindestens PHP 8.1.0.

Viele Grüße

ojeh, ja danke ! entschuldigt bitte

1 Like

@shyim

Mit

composer create-project shopware/production:dev-flex shopware-flex

bekomme ich folgend Fehlermeldung.

  - Syncing shopware/production (dev-flex 929d5a5) into cache
Cloning failed using an ssh key for authentication, enter your GitHub credentials to access private repos

Welche repos sind denn private?

Die Grund Installation funktioniert.
Am Ende des Assistenten (nach dem ersten login) erhalte ich Popups mit error 500.

Wenn ich jetzt auf die Seite neu lade, bekomme ich folgende Anzeige:

{

    "errors": [
        {
            "code": "0",
            "status": "500",
            "title": "Internal Server Error",
            "detail": "[Semantical Error] The annotation \"@Shopware\\Core\\Framework\\Routing\\Annotation\\RouteScope\" in class Nwdxx\\ItRechtConnector6\\Controller\\LegalController was never imported. Did you maybe forget to add a \"use\" statement for this annotation? in /Users/ansolas/Sites/shopware-65-rc-dev/custom/plugins/nwdxxItRechtConnector6/src/Resources/config/./../../Controller/LegalController.php (which is being imported from \"/Users/ansolas/Sites/shopware-65-rc-dev/custom/plugins/nwdxxItRechtConnector6/src/Resources/config/routes.xml\"). Make sure there is a loader supporting the \"annotation\" type."
        }
    ]

}

Das Plugin ist noch kompatibel.

sehe ich auch gerde, wieder zu schnell irgendwelchen vorschlaegen geglaubt :slight_smile:

Die vorgeschlagenen Plugins sind zu 99% noch nicht mit 6.5 kompatibel.