Shopware 6 Sicherheits-Plugin. Update auf Version 2.0.2: Internal Server Error

Hallo zusammen,

hat noch jemand das gleiche Problem? Es geht um Shopware 6 Sicherheits-Plugin. Update auf Version 2.0.2 bringt Fehlermeldung „Internal Server Error“:

=========================

Attempted to load class „UpdateHtaccess“ from namespace „Swag\Security\Components“. Did you forget a „use“ statement for „Shopware\Core\Framework\Update\Services\UpdateHtaccess“?

=========================

Hätte ich allen gehabt, dann würde vielleicht nicht fragen, aber es sind drei verschiedene Shop mit dem gleichen Ergebnis. Es handelt sich scheinbar um einen Fehler in der Programmierung. Die Fehlermeldung besagt, das anscheinend eine Klasse nicht geladen werden kann „UpdateHtaccess“. Hier kann die Ursache sein, dass eine bestimmte Datei vergessen wurde einzubinden (use), welche die Klasse entweder erstellt oder in dieser angelegt ist.

Ich freue mich auf eine Antwort.

Mit besten Grüßen
Lago

Moin Lago,

vielleicht wieder ein Problem mit dem OPCache? Alle drei Shops mit OPAchea vielleicht und dort liegen noch Reste einer alten Version? Setzt den OPCache mal mit deinem Hoster zurück.

VG Benjamin

danke für den hinweis. werde auch erstmal eine updatepause einlegen. da ist irgendwie gerade der wurm drin.

Hallo Benjamin,

Danke für die schnelle Antwort. :slight_smile:

Ja, ich habe auch schon so gedacht und habe All Inkl bereits angeschrieben. MAl schauen was die sagen. Aber die erste Vermutung ist wie gesagt, dass eine bestimmte Datei vergessen wurde einzubinden (use), welche die Klasse entweder erstellt oder in dieser angelegt ist.

Ich melde mich sobald ich Antwort von All Inkl kriege. :wink:

Mit besten Grüßen
Lago

Hallo zusammen,

OPCache gelöscht, Cache geleert und aufgewärmt, Update gestartet, gleiche Fehlermeldung erhalten. D.h. es liegt doch nicht an OPCache…

Mit besten Grüßen
Lago

Hab das Problem auch, hab das update mal liegen lassen.

Vielen Dank für die Meldung!

Also, dann sind doch mehrere betroffen. Ich tippe jetzt auf eine Datei, die beim letzten oder aktuellem Update fehlerhaft war/ist. :slight_smile:

Habe ebenfalls die gleiche Fehlermeldung. Hosting auch bei all-inkl …

Edit: Das Update von Shopware 6.5.7.2 auf 6.5.8.2 hat am Problem auch nichts geändert. Kann das Sicherheitsplugin nicht mehr installieren.

Attempted to load class "UpdateHtaccess" from namespace "Swag\Security\Components". Did you forget a "use" statement for "Shopware\Core\Framework\Update\Services\UpdateHtaccess"?

Schliesse mich an, wir sind bei DF auf 6.5.7.3, gleicher Fehler…

Ist das Security-Plugin nicht einfach der Plan B, wenn ich Lücken nicht mehr per Update patchen kann, weil hier entweder keins mehr rauskommt, oder ich aus irgendwelchen Gründen damit noch warten muss.

Ich frag, weil dann für die neuste Core-Version und die, die noch gepatcht werden/wurden ja niemand einfach mal prophylaktisch ein Security-Plugin installieren muss.

Wenn ich mein Security-Plugin dann genau so schlecht mit Updates versorge wie den Core, hab ich evtl. so gar nichts dabei gewonnen. Oder?

Hallo zusammen,

Nachtrag. Jetzt ist auch Plugin „Shopware Store“ betroffen. Wenn man den aktualisieren will dann wird alles zerschossen… Und das sind alles eigene Plugins von Shopware… Von anderen Anbietern läuft alles wie es sein muss. :slight_smile:

Mit besten Grüßen
Lago

Kann ebenfalls nicht updaten

Nabend,

OPcache schon als Ursache ausgeschlossen?

Determine your PHP method

Anwendung auf eigene Gefahr und nur mit entsprechendem Wissen/Backup bitte :slight_smile:. Ansonsten Hoster ansprechen.

VG Benjamin