Shopware 6 development version installation error.


I am trying to install shopware6 on ubuntu. I got the following error when I am trying to install using the command ./psh.phar install

"ERROR 2059 (HY000)Authentication plugin ‘caching_sha2_password’ cannot be loaded: /usr/lib/x86_64-linux-gnu/mariadb18/plugin/
cannot open shared object file: No such file or directory

Execution aborted, a subcommand failed!"

I am using 

ubuntu 19.04

Php 7.2 

Mysql 5.7.27

I have tried this 

ALTER USER root@localhost IDENTIFIED WITH mysql_native_password BY ‘password’;

But not working.

Anyone can help me?

1 Like

Please follow the following instructions in order to complete the developer version installation

  1. You can skip the ‘caching_sha2_password’ issue by using MySQL 5.7.28 image in docker file (Mysql 8 is the cause of this error)

   dev-ops/docker/containers/mysql/Dockerfile FROM mysql:8 -> FROM mysql:5.7.28

  1. docker commands should run without sudo command

   “docker info” - If you got an error related to permission please run the following command

   “sudo chmod 666 /var/run/docker.sock” - Then check again “docker info”

   if it is ok please follow the installation.

  1. You need to set the permissions of the folders. (Installation will stop many times with permission issue message)

  2. Set permissions and continue the installation

  3. At last, it will be installed :slight_smile:

1 Like

Mysql 8 error can be solved by adding “command: --default-authentication-plugin=mysql_native_password” in docker-compose.yml in root folder.

build: dev-ops/docker/containers/mysql
command: --default-authentication-plugin=mysql_native_password