sComment ist leer

Moin,

 

sComment ist leer. Kundenkommentare werden nicht geschickt.

 

 

 

Aufgefallen ist mir dann, dass es 2 sComment felder gibt. Wobei nur eines gesendet wird.

Das erste Feld ist, wie ersichtlich, hidden. Wenn genau dieser Knoten gekösht wird, dann wird gar kein sComment als Parameter übergeben.

 

 

 

Das ist echt komisch, verstehe den Grund nicht. Bitte um Hilfe =)

 

Hallo,

die zwei Felder sind schon richtig so.

Bei dem einen Feld, das ein Textarea und nicht versteckt ist, gibst du den Inhalt ein. Dieses befindet sich aber außerhalb des Formulares, das beim Absenden der Bestellung versendet wird. Damit die Eingabe in das Textarea übernommen wird, wird der Inhalt des Textareas beim Eingeben über jQuery in das versteckte Feld übertragen, das sich im Formular befindet, das versendet wird.

Wenn das versteckte Feld leer ist, kann das beispielsweise durch einen JavaScript - Fehler passieren, hier sollte man mal die Konsole prüfen. Ebenso wäre es auch relevant zu wissen, welche Shopware Version im Einsatz ist, da es in früheren Versionen bei dem Bereich mal Probleme gab.

Beste Grüße

Sebastian

1 Like

Ok, komisch, dass das Kommentar auch nicht gesendet wird, wenn das beide Felder per Hand ausgefüllt werden.

Vielleicht wird das Kommentar genau dann ausgefüllt, wenn der Submit-Button geklickt wurde und ich bekomm das so einfach nichtmehr nicht ^^

Habs gefunden!! Lag wirklich daran, dass irgendiwie genau dieses Feld nach klicken des Submit-Buttons geleert wurde. So knifflig =/