Produktslider Pfeile verschwunden. Kunden haben sich ebenfalls angesehen.

Seit einem der letzten Updates sind die Pfeile für die Produkt Slider verschwunden.Die vertikale Ausgabe ist behoben. Nur bleiben die Pfeile weg und der Produktslider ist nicht scrollbar.
Weitere Artikel sind vorhanden (im chrom tool zu sehen). Ich vermute eine Fehler in der detail.less oder image-slider.less
Da sie noch orginal vom responsive genommen werden müßten mehrere das Problem haben. Es muss mit einem Update zu tun haben da zwischen diesen keine Veränderungen vorgenommen wurden und es bis dahin immer funktionierte.
Die product-slider.less

.product-slider--container {
    .clearfix();
	.user-select(none);
	.touch-callout(none);
	.tap-highlight-color(rgba(0, 0, 0, 0));
	display: block;
	width: 100%;
	height: 100%;
	font-size: 0; // Remove auto whitespace between inline elements
    position: relative;
	top: 0; left: 0;
	overflow: hidden;
	-webkit-overflow-scrolling: touch; // Enable momentum scrolling

	// Hide scrollbars in webkit browsers
	&::-webkit-scrollbar {
		width: 0;
		height: 0;
	}

	&.is--vertical {
		overflow-y: scroll;
		overflow-x: hidden;

		.product-slider--item {
			display: block;
            width: 100%;
		}
	}

	&.is--horizontal {
		overflow-y: hidden;
		overflow-x: scroll;
		white-space: nowrap;

		.product-slider--item {
            height: 100%;
			display: inline-block;
		}
	}

	.is--ie &,
	.is--firefox &,
	&.is--no-scroll {
		overflow-y: hidden;
		overflow-x: hidden;
	}
}

.product-slider--item {
    .unitize-padding(10, 10);
	.unitize(font-size, 16);
	.user-select(none);
	.touch-callout(none);
	.tap-highlight-color(rgba(0, 0, 0, 0));
    position: relative;
	top: 0;
    left: 0;
	overflow: hidden;
	text-align: center;

}

 

Schalte doch mal zu Testzwecken auf das original Responsive (ohne Änderungen) um zu schauen ob es da funktioniert, damit hast du den Fehler dann schon mal eingegrenzt

Uwe

1 Like

Das sind sie vorhanden?? Nur an den less dateien für den Slider habe ich nichts geändert. Allerdings zeigt mir der inspector eine rote fehlermeldung:
Stil Dokument konnte nicht geladen werden. https://maxcdn.bootstrapcdn/font-awesome/4.4.0/css/font-awesome.min.css
Bekomme ich öfters. Wieso von ausserhalb? Benenne jetzt pö a’ pö alles less die geändert wurden um und lösche jedesmal den Templatecache. Bzw. nehme sie aus der all.less

 

Hat sich erledigt. Es muss einer der tpl gewesen sein die sich geändert hat. Hatte einige vorsichtshalber in mein templateverzeichnis kopiert um mir die anzusehen und dabei war wohl auch die tpl.datei die sich geändert hat. Ausser im blog habe ich noch keine geändert. Da kann man sich aber auch dumm suchen bei so vielen Verzeichnissen und Dateien wenn man nicht ständig dran sitzt.
Danke für den Tipp. Es waren zwar nicht die less aber dadurch bin ich auf die tpl gekommen.