Produktkonfigurator auf mobile verursacht unendlichen Ladescreen

Hallo,

ich habe derzeit ein großes Problem auf der mobilen Ansicht. Wenn ich im Produktkonfigurator meine Auswahl tätige und anschließend auf „Menü schließen“ klicke, erscheint das Loading Gif, welches nicht mehr verschwindet und somit die Seite nicht mehr navigierbar ist.

Benötige dringend Hilfe bitte!

EDIT: Nachdem ich Shopware auf die neuste Version aktualisiert habe ist das Problem auf dem Desktop und auf Android Geräten verschwunden.
Auf Apple Geräten besteht das Problem weiterhin. Es scheint ein generelles Apple Problem zu sein.

Ich benutze Shopware 5.4.5
Google Enhanced Ecommerce 2.0.2
Konfigurator-Typ pro Konfigurator-Gruppe 1.0.2
Zusätzliche Tabs, Eigenschaften- und Downloads-Tabs für die Artikeldetailseite 2.0.21
zendesk chat 2.0.2

Alle Plugins sind aktuell.
In der Konsole bekomme ich keine JavaScript Fehler
 

Niemand eine Idee woran es liegen könnte?

Hast du mal die Plugins alle nacheinader ausgemacht? 

@AndreHerking schrieb:

Hast du mal die Plugins alle nacheinader ausgemacht? 

Habe ich soeben probiert, jedes Plugin nach und nach ausgeschaltet, um auszuschließen, dass es daran liegt.
Im Syslog ist mir folgendes aufgefallen:
 

ERROR: exception 'Shopware\Components\CSRFTokenValidationException' with message 'The provided X-CSRF-Token for path "/newsletter" is invalid. Please go back, reload the page and try again.' in /engine/Shopware/Components/CSRFTokenValidator.php:149 Stack trace:
#0
CRITICAL: The provided X-CSRF-Token for path "/newsletter" is invalid. Please go back, reload the page and try again.

Wenn ich die Fehlermeldung Google berichten einige User, dass dies ähnliche Probleme im Produktkonfigurator verursacht hat wie jetzt bei mir.
Wie kann ich den Fehler beheben?

 

Hallo nochmal,

da ich bisher keine Hilfe oder selbst eine Lösung finden konnte schreibe ich erneut.
Dass der Shop Konfigurator auf Apple Geräten derzeit gar nicht läuft, ist für mich ein riesen Problem.
Was kann ich tun, um hier Hilfe zu bekommen?

Ich habe bereits gelesen, dass es für die Community Edition keinen buchbaren Support gibt.
Was für andere Möglichkeiten habe ich nun, um von Shopware Hilfe zu bekommen?

Zwecks fehlender Fehlermeldungen und mangelnden Shopware Kenntnissen komme ich zu keiner Lösung.

Bitte somit erneut dringend um Hilfe.

Sehe ich das richtig? Großes dringendes Problem und keine URL dazu?

1 Like

@SB schrieb:

dringend dringend - keine agentur gebucht, die helfen kann - keine shopware pro lizenz - support dringend bitte umsonst. selbst in die kostenlose community edition einarbeiten = keinen bock.

Aus diesem Grund frage ich, was ich ohne Lizenz tun kann. Ich bin bereit zu zahlen. Ich kann nur mit der Community Version keinen Support beantragen. Ich habe mich in die kostenlose Variante eingearbeitet, jedoch wenn man keine Fehlermeldungen vom System oder der Browserkonsole zurück bekommt und schon per Ausschlussverfahren keinen Erfolg sieht, bin ich langsam ratlos. Verstehe nicht warum direkt so frech geantwortet wird. Es ist nunmal ein schwerwiegendes Problem für meinen Shop und ich wollte hiermit fragen, was ich tun kann, um Hilfe zu bekommen. 

Und mit Hilfe meine ich nicht nur kostenlose Hilfe. Natürlich wäre ich dankbar, wenn es auch so lösbar wäre. Aber derzeit weiß ich nicht, wie ich für die Community Edition mit meinem Problem Support erhalte, daher meine Frage !!!

@Rednaxela schrieb:

Sehe ich das richtig? Großes dringendes Problem und keine URL dazu?

Es geht um https://moebelundkonsorten.de
Habe zunächst die URL nicht gepostet, da ich überhaupt erstmal auf eine Antwort gehofft habe.

Konnte das Problem mittlerweile selbst lösen.

Wer mal selbiges Problem mit dem Safari hat:

Der Browser kann nicht mit   (jQuery); am ende einer jQuery Funktion umgehen. Die Konsole meldet hier, dass die Funktion unbekannt ist.
Das Problem existiert nur im Safari Browser. Wer also Custom Scripts schreibt und vor allem sie mit der Shopware §.subscribe Methode wie in der Wiki
in eine (jQuery) Funktion wrapped, könnte Probleme bekommen. Zumindest war das explizit in meinem Fall so. Debugging war schwierig, da ich keinen Mac besitze und
der Safari für Windows nicht equivalent zur Mac Version ist. Daher ist es zudem ratsam die Dev Tools auf einem Mac zu nutzen.