Probleme nach Update 6.3.5.1

Seit dem letzten Update auf 6.3.5.1 haben wir einige Probleme.

  • Sortieren nach negativ Bestand im Backend funktioniert nicht korrekt.
  • Deinstallation der Plugins funktioniert nicht mehr: Das Plugin konnte aufgrund der Fehlermeldung “Call to a member function getConfigFromBundle() on null” nicht deinstalliert werden
    • Extrem ärgerlich, da Test Plugins in der Testphase nicht mehr deinstalliert werden können.

Ist jemandem eventuell Gleiches aufgefallen?

Hi,

bzgl. Plugins:

Unser System läuft derzeit auf 6.4.5.0 und bei uns werden die Plugins ohne Probleme deinstalliert.

An der Version 6.3.5.1 wird es nicht liegen, da dies nur ein Sicherheitsupdate war/ist, wenn dann an den vielen Änderungen von 6.4.5.0.

Am besten einmal bin/console plugin:refresh && bin/console plugin:uninstall PLUGIN_NAME ausführen ggf. einmal den Cache löschen.

 

Hallo tneumann,

vielen Dank für deine Hilfe. Leider erscheint auch in der Console der Error "  Call to a member function getConfigFromBundle() on null  ". Ich kann dazu in der Shopware Doku auch nichts finden… Hast du eventuell noch eine weitere Idee für mich?

Du bekommst warscheinlich auch keine Ausgabe bei „bin/console plugin:refresh“ , richtig?

Wie sieht deine Composer.json aus? Und deine PHP Datei die von Plugin extended?

 

Die Funktion getConfigFromBundle findest du in vendor/shopware/core/System/SystemConfig/Service. Dort ruft er über den configReader diese Funktion auf. Die Fehlermeldung bedeutet für mich das der configReader im Container nicht existiert. Deswegen on null.

Benutzt du Docker oder ähnliches? 

Ich würde mal den vendor Ordner löschen und dann ein composer install machen.

 

Hallo,

wir haben nach dem Update 6.3.5.1 (wahrscheinich seit 6.3.5.0) festgestellt, dass bei den Produkten --> SEO die Schlüsselwörter weg sind und neue speichern konnten wir nicht!
Ist der Fehler bekannt? In der Datenbank, habe ich noch nicht nachgeschaut.

Wir haben zwei SHOPs laufen und bei beiden funktiert es nicht Blush

 

1 Like

@Kereem schrieb:

Hallo,

wir haben nach dem Update 6.3.5.1 (wahrscheinich seit 6.3.5.0) festgestellt, dass bei den Produkten --> SEO die Schlüsselwörter weg sind und neue speichern konnten wir nicht!
Ist der Fehler bekannt? In der Datenbank, habe ich noch nicht nachgeschaut.

Wir haben zwei SHOPs laufen und bei beiden funktiert es nicht Blush

 

Bei mir speichert es alles.