Problem Backend Kundenübersicht

Ich habe mit einem Benutzer unter Shopware 5.3.3 das Problem, das beim Aufruf der Kundenübersicht erst eine Art Übersicht erscheint, welche ich überspringen bzw mit ‚Weiter‘ bis zum Punkt ‚Zum Modul‘ gelange. Dann wird aber das Backend neu geladen und ich komme so nicht in die Kundenübersicht. Ein andere Admin Benutzer hat dieses Problem nicht. Im Log steht folgendes

 

Enlight_Controller_Exception: Permission denied in /engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php:254 Stack trace:
#0 /engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php(207): Shopware_Plugins_Backend_Auth_Bootstrap->checkAuth()
#1 /engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware_Plugins_Backend_Auth_Bootstrap->onPreDispatchBackend(Object(Enlight_Controller_ActionEventArgs))
#2 /engine/Library/Enlight/Event/EventManager.php(214): Enlight_Event_Handler_Plugin->execute(Object(Enlight_Controller_ActionEventArgs))
#3 /engine/Library/Enlight/Controller/Action.php(137): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs))
#4 /engine/Library/Enlight/Controller/Dispatcher/Default.php(530): Enlight_Controller_Action->dispatch('loadStreamActio...')
#5 /engine/Library/Enlight/Controller/Front.php(223): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#6 /engine/Shopware/Kernel.php(189): Enlight_Controller_Front->dispatch()
#7 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(491): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#8 /engine/Shopware/Components/HttpCache/AppCache.php(268): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#9 /vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#10 /engine/Shopware/Components/HttpCache/AppCache.php(105): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)

 

Gebe ich dem genannten Benutzer Admin Rechte, kann ich zwar ins Kundenmenü, allerdings erscheint immer wieder dieser „Willkommensbildschirm“. Der genannte Benutzer hat u.a. die Rechte ‚Article Read‘, ‚Article Save‘, ‚Article Delete‘, Wo liegt der Fehler?

Ich konnte das Problem teilweise lösen. Ich habe im Endeffekt die Rolle mit gleichen Rechten neu angelegt und dort dann den User neu zugeordnet. Das hat soweit funktioniert. Ein kleines Problem besteht aber immer noch. Es erscheint bei jedem Aufruf das folgende Bild

Wie kann ich diese Anzeige dauerthaft deaktivieren?

Hallo zusammen,

leider lässt sich auch bei mir die Kundenübersicht als Benutzer nicht aufrufen. Mit einem Admin-Account ist es kein Problem.

Wenn ich mich als Benutzer im Backend einlogge, erscheint kurz die Kundenübersicht aber das Fenster stürzt direkt ab und das Backend wird neu geladen.

Leider kann ich dem Kunden kein Admin-Zugriff geben. Ich habe die neuste Version (5.4.1) im Einsatz.

Ich habe die Rolle mittlerweile neu erstellt und dem User neu zugewiesen. Leider ohne Erfolg.

Kann das Problem jemand bestätigen?

Der User benötigt auch Zugriff auf die Customer Streams

1 Like

Vielen Dank! Genau das war es :slight_smile:

Stand auch so im Handbuch. Habe es leider nicht gesehen.  Halo