Plugininstallation mit @dev-Version

Hallo!

Wie kann man Plugins installieren, die mit

“require”: {

        “shopware/core”: “~6.1.0”

gekennzeichnet sind, ich aber mit der “6.2.x@dev” arbeite?

Will ich das Plugin installieren, kommt die Fehlermeldung:

  Could not install plugin, got 1 failure(s).

  Required plugin/package “shopware/core ~6.1.0” does not match installed version 6.2.9999999.9999999-dev.

Die installierte Version ist doch höher und sollte damit funktionieren!?

Oder wie kann ich die lokale Version überschreiben, sodass sich die Pluginabhängigkeiten auflösen lassen?

Danke!

Eventuell so?

composer require "swag/plugin-config @dev" --ignore-platform-reqs

 

1 Like