Plugin Logo Größe anpassen

[quote=“useg”]Da ich auch ein großes Logo habe (300x150px) ich habe das Logo erst mal in der Desktop-Ansicht mit: @media screen and (min-width: 48em) { .header-main .logo-main {.unitize(margin-top,-30)} .header-main .logo-main .logo--shop {.unitize(height,150)} .header-main .logo-main .logo--link {.unitize(height,150)} } nach oben geschoben. So ragt das Logo in die Top-Bar hinein. Wie ich es bei den anderen Ansichten mache muss ich erst noch ausprobieren.[/quote] Du arbeitest aber mit Version 4.3.2 oder?

@kayyy Ist zwar ein wenig Off-Topic, aber ich frage trotzdem mal. Ich fange gerade an, mich mit shopware auseinanderzusetzen und habe dementsprechend noch keine Erfahrungen. Wenn Du schreibst, dass man die topbar ausblenden könnte. Welches wäre der eleganteste Weg zum Ausblenden der Topbar? Du würdest es ja sicherlich nicht direkt in der topbar-navigation.tpl machen. Würdest Du es über ein Plugin ausblenden oder über ein neues (auf Standardtemplate basierendes) Theme realisieren? Oder würdest Du es ganz anders (vielleicht viel einfacher) machen? Viele Grüße canetti

[quote=“videho”][quote=“kayyy”][quote=“canetti2”]Anbei mal eine Grafik zur Veranschaulichung. [/quote][/quote] Im angehängten Bild sieht man, dass das Logo nicht gut positioniert ist. [/quote] Jap - das liegt an der topbar. Aber vielleicht bekommen wir es ja auch mit dem negativen margin gut hin :slight_smile: Kannst du evtl. einmal die IP 37.24.154.36 zu deinem Wartungsmodus hinzufügen, da ich sonst das gnaze nicht wirklich sehen kann. Ich habe das Plugin hier schon einmal dahingehend geupdatet, dass man das Suchfeld mittig setzen kann oder nicht. Und useg arbeitet mit Shopware 5 nicht 4 :slight_smile:

1 Like

[quote=„canetti2“]@kayyy Ist zwar ein wenig Off-Topic, aber ich frage trotzdem mal. Ich fange gerade an, mich mit shopware auseinanderzusetzen und habe dementsprechend noch keine Erfahrungen. Wenn Du schreibst, dass man die topbar ausblenden könnte. Welches wäre der eleganteste Weg zum Ausblenden der Topbar? Du würdest es ja sicherlich nicht direkt in der topbar-navigation.tpl machen. Würdest Du es über ein Plugin ausblenden oder über ein neues (auf Standardtemplate basierendes) Theme realisieren? Oder würdest Du es ganz anders (vielleicht viel einfacher) machen? Viele Grüße canetti[/quote] Es würde drei Varianten geben. 1) Quick & Dirty über die CSS mit display:none; 2) Block direkt im Template ausblenden 3) Plugin

[quote=“kayyy”] Kannst du evtl. einmal die IP 37.24.154.36 zu deinem Wartungsmodus hinzufügen, da ich sonst das gnaze nicht wirklich sehen kann. [/quote] Deine IP ist frei!!

Ok, speziell die Variante 1 wären nicht wirklich “elegant”. Und bei der Variante 2 hätte man evtl. auch ein Problem beim Softwareupdate. Es wäre super, wenn Du Dein Plugin um ein negatives margin-top erweitern könntest. Ich denke, dass sollten die meisten (halbwegs aktuellen) Browser mittlerwele beherrschen :wink:

Ich habe das Plugin jetzt einmal dahingehend erweitert, dass man einen Abstand für das Logo nach oben festlegen kann ( auch negativ ) und den Abstand der Shopnavigation nach oben angeben kann. Möchtet Ihr also das Logo nach oben verschieben, gebt bspw. -50 ein.

1 Like

Sorry, aber wie installiert man dein Update?

1 Like

[quote=„videho“][quote=„useg“]Da ich auch ein großes Logo habe (300x150px) ich habe das Logo erst mal in der Desktop-Ansicht mit: @media screen and (min-width: 48em) { .header-main .logo-main {.unitize(margin-top,-30)} .header-main .logo-main .logo--shop {.unitize(height,150)} .header-main .logo-main .logo--link {.unitize(height,150)} } nach oben geschoben. So ragt das Logo in die Top-Bar hinein. Wie ich es bei den anderen Ansichten mache muss ich erst noch ausprobieren.[/quote] Du arbeitest aber mit Version 4.3.2 oder?[/quote] Nein mein Testshop läuft mit SW5 und es wird noch ne weile dauern bis ich alles fertig habe.

[quote=“kayyy”][quote=“videho”]Sorry, aber wie installiert man dein Update?[/quote] Da das ganze nicht im Store verfügbar ist geht hier das automatische Update nicht. Lösche mal das Plugin und lade das neue hoch. Den letzten Release kannst du hier downloaden: https://github.com/hostianer/HostiLogo/releases[/quote] nimm mir’s nicht übel, aber die Version 1 hatte einen anderen Inhalt als Version 1.2. Wie installiert man den den Inhalt von v 1.2?

1 Like

[quote=“videho”][quote=“kayyy”][quote=“videho”]Sorry, aber wie installiert man dein Update?[/quote] Da das ganze nicht im Store verfügbar ist geht hier das automatische Update nicht. Lösche mal das Plugin und lade das neue hoch. Den letzten Release kannst du hier downloaden: https://github.com/hostianer/HostiLogo/releases[/quote] nimm mir’s nicht übel, aber die Version 1 hatte einen anderen Inhalt als Version 1.2. Wie installiert man den den Inhalt von v 1.2?[/quote] Das ist leider ein wenig doof an Github gerade mit Shopware :slight_smile: Lade dir noch einmal die 1.3 runter. Entpacke Den Ordner un nenne den entpackten Ordner HostiLogo-1.3 ind “HostiLogo” um. Uploade diesen Ordner dann nach engine/Shopware/Plugins/Local/Frontend

Entschuldige, hatte die Installationsroutine verwechselt. Vergiss meinen letzten Beitrag. Vielen Dank fir für deine Mühe, die du dir mit uns Anfängern machst!

[quote=„videho“]Entschuldige, hatte die Installationsroutine verwechselt. Vergiss meinen letzten Beitrag. Vielen Dank fir für deine Mühe, die du dir mit uns Anfängern machst![/quote] Kein Problem - Funktioniert es denn nun ? :slight_smile:

1 Like

Super :thumbup:

1 Like

Funktioniert super Dein Plugin. Vielen Dank für Deine Mühe - ich bin begeistert!!!

Bei mir funktioniert es leider nicht. 1.3 runtergeladen, installiert, 100 px eingegeben als Höhe … oder auch mehr, es verändert sich leider nichts. Cache geleert, auch nicht. Bug? Danke trotzdem =)

[quote=“mwhardware”]Bei mir funktioniert es leider nicht. 1.3 runtergeladen, installiert, 100 px eingegeben als Höhe … oder auch mehr, es verändert sich leider nichts. Cache geleert, auch nicht. Bug? Danke trotzdem =)[/quote] Hast du auch den ThmenCache neu aufgebaut? Allein den normalen Cache leeren bringt nichts.

Neben dem Shopware Cache auch einmal unbedingt den Browser Cache leeren.