php_network_getaddresses: getaddrinfo failed: Name or service not known  

Hallo!
 

bei dem Ticket https://forum.shopware.com/discussion/comment/217868#

hab ich dann diesen Befehl ausgeführt:

ok mach mal ./psh.phar docker:start,docker:ssh und dann ./psh.phar init

nach dem Befehl /psh.phar init

gibt es hier einen Fehler, gibt es dazu noch eine Lösung?

 

Danke

      [PDOException]                                                                                  

      SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known  

   [PDOException]                                                                              

      PDO::__construct(): php_network_getaddresses: getaddrinfo failed: Name or service not known  

   install:release [-r|–release RELEASE] [-i|–install-dir INSTALL-DIR] [–db-host DB-HOST] [–db-port DB-PORT] [–db-socket DB-SOCKET] [–db-user DB-USER] [–db-password DB-PASSWORD] [–db-name DB-NAME] [–no-skip-import] [–shop-locale SHOP-LOCALE] [–shop-host SHOP-HOST] [-p|–shop-path SHOP-PATH] [–shop-name SHOP-NAME] [–shop-email SHOP-EMAIL] [–shop-currency SHOP-CURRENCY] [–skip-admin-creation] [–admin-username ADMIN-USERNAME] [–admin-password ADMIN-PASSWORD] [–admin-email ADMIN-EMAIL] [–admin-locale ADMIN-LOCALE] [–admin-name ADMIN-NAME]

Execution aborted, a subcommand failed!

 

danke

lg

Peter

Hallo,

 

der Fehler sagt aus, dass eine Domain unter den angegeben Namen nicht zu erreichen ist. Er versucht hier den Domain Namen zu einer IP aufzulösen und das klappt nicht, weil es die Domain nicht gibt.

 

 

MFG

 

derwunner

herzlichen Dank, d. h. ich muss eine Domain vorschalten sonst geht es nicht

d. h. ich brauche eine Domain?

kann ich auch eine IP verwenden, kann man das irgendwo konfigurieren oder funktioniert eben nur mit einer Domain

und wenn eine Domain, wo kann ich die konfigurieren oder genügt es einfach die VPS in der DNS mit der Domain zu verknüpfen?

 

danke

@derwunner schrieb:

Hallo,

 

der Fehler sagt aus, dass eine Domain unter den angegeben Namen nicht zu erreichen ist. Er versucht hier den Domain Namen zu einer IP aufzulösen und das klappt nicht, weil es die Domain nicht gibt.

 

 

MFG

 

derwunner

 

hallo, hab jetzt eine Domain eingebunden

http://jove.ovh

geht aber noch immer nicht nach dem Befehl

wie kann ich diesen Fehler beheben?danke

root@vps18066:~/shopware-docker# ./psh.phar init

 

 

###################

Starting Execution of ‘init’ (‘dev-ops/common/actions/init.sh’)

 

 

(1/2) Starting

> rm -rf ./shopware

    

(2/2) Starting

> ./sw.phar install:release -r latest -i ./shopware --db-host mysql --db-user app --db-password app --db-name shopware --shop-host 10.100.111.46

    Downloading release

    Unzipping archive

    Creating database shopware

    

                                                                                                      

      [PDOException]                                                                                  

      SQLSTATE[HY000] [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known  

                                                                                                      

    

                                                                                                   

      [PDOException]                                                                               

      PDO::__construct(): php_network_getaddresses: getaddrinfo failed: Name or service not known  

                                                                                                   

    

    install:release [-r|–release RELEASE] [-i|–install-dir INSTALL-DIR] [–db-host DB-HOST] [–db-port DB-PORT] [–db-socket DB-SOCKET] [–db-user DB-USER] [–db-password DB-PASSWORD] [–db-name DB-NAME] [–no-skip-import] [–shop-locale SHOP-LOCALE] [–shop-host SHOP-HOST] [-p|–shop-path SHOP-PATH] [–shop-name SHOP-NAME] [–shop-email SHOP-EMAIL] [–shop-currency SHOP-CURRENCY] [–skip-admin-creation] [–admin-username ADMIN-USERNAME] [–admin-password ADMIN-PASSWORD] [–admin-email ADMIN-EMAIL] [–admin-locale ADMIN-LOCALE] [–admin-name ADMIN-NAME]

    

    

Execution aborted, a subcommand failed!

 

root@vps18066:~/shopware-docker#

Hi zusammen,

ist hierfür schon eine Lösung gefunden worden?

ok mach mal ./psh.phar docker:start,docker:ssh und dann ./psh.phar init

hat bei mir geholfen.

Ich habe das gleich Problem nach einem Update. Wo muss ich diese Befehle eingeben? In einer SSH Shell bekomme ich nur die Meldung, dass die Befehle unbekannt sind.