Parse Error bei Installation

Hallo bekomme folgenden Parse Error bei der Installation: “Parse error: syntax error, unexpected ‘[’, expecting ‘)’ in /www.meinedomain/recovery/install/index.php on line 55” Komisch RC 1 und 2 konnte ich ohne Probleme installieren… Jamand eine Idee? Danke

Hmm habe jetzt mal die [ in Zeile 55 der index.php entfernt. Jetzt habe ich keinen Parse Error mehr bekommen, sondern die Meldung: “Auf Ihrem Server läuft PHP version 5.3.28-nmm2, Shopware 5 benötigt mindestens PHP 5.4.0” Es läuft aber 5.6 auf dem Server. Jetzt habe ich wie im anderen Thread beschrieben die .htaccess geändert und folgendes hinzugefügt: AddHandler php56-cgi .php Jetzt ging die Installation, allerdings mit dem mod_rewrite error, den ich ignoriert habe. Komme jetzt aber nicht ins Backend, da ich wieder die Fehlermeldung “Auf Ihrem Server läuft PHP version 5.3.28-nmm2, Shopware 5 benötigt mindestens PHP 5.4.0” bekomme… Muss ich jetzt jede htaccess ändern oder was ist da los?

habe jetzt die .htaccess geändert und jetzt bin ich im backend. Mal sehen wann die nächste Fehlermeldung kommt…

1 Like

Hallo zusammen, nach langer GAMBIO-Zeit habe ich mich heute mal auf ShopWare CE 5 eingelassen und hab auch gleich die erten Probleme bei der Installation. Hoffe es kann mir hier jemand weiterhelfen. Nach erfolgreicher Datenbank-Installation bekomme ich die Fehlermeldung: Parse error: syntax error, unexpected ‚extends‘ (T_EXTENDS), expecting identifier (T_STRING) in /usr/www/users/skinfo/skinfox.de/cache/production_201504271122/doctrine/attributes/.php on line 38 Ich hab keinen Plan - Hoffe auf Euer Hilfe. Thx

Hallo, Da gibt es eine kaputte Cache Datei. Lösche die mal aus dem angegebenen Pfad. Die heißt nur .php ohne einen eigenen Namen. Die wird eigentlich nur erzeugt wenn noch andere Tabellen neben denen von Shopware in der Datenbank sind. Kann sein das dein FTP Programm die nicht anzeigt weil die mit . Beginnt. Da musst du irgendwo einstellen das es versteckte Daten anzeigt. Grüße Moritz

2 Likes

Hallo Moritz, vielen herzlichen Dank für Deine Blitz-Antwort. TOP-Service - nach dem Löschen der .php-Datei war sofort alles i.O. Und ich dacht schon ich muß jetzt die Feiertage wartend verbringen :). TOP und nachmals Danke - bin im Backend. Gruß

Hallo zusammen, ich erhalte den gleichen Fehler wie Skinfox! Also habe ich ebenfalls versucht, die .php aus dem Cache zu löschen. Beim aktualisieren des Browsers wird die .php aber immer wieder neu erstellt. Ich dreh mich hier im Kreis und komme nicht weiter. Shopware 4 läuft ohne Probleme. Hat jemand vielleicht noch eine Idee für mich? Viele Grüße Hab es dann doch hinbekommen. Ich habe einmal bei meinem Provider die Datenbank gelöscht und neu erstellt. Danach hat die Installation einwandfrei funktioniert!

1 Like

Hi, schaue mal in deine .php-Datei. Dort müsste soetwas drin stehen: * @ORM\Table(name="**_attributes") Die dort genannte MySQL-Tabelle musst du löschen. Dann dürfte die .php-Datei auch nicht mehr angelegt werden. Gruß Heiner

1 Like

Hallo Zusammen,

Wo finde ich eine Ausfuehliche Installation Einleitung?

Ich habe das Paket heruntergeladen und geoeffnet. Ich sehe im Paket keine ausfuehrbare datei. Wie geht es weiter?

Danke fuer eure Hilfe,

Clde

Hallo,

ausführliche Installationsanleitungen findest du hier:

Am besten du startest die Installation über www.deinedomain.de/recovery/install/index.php

Beste Grüße

Sebastian

Vielen Dank an Heiner Lohaus!

Wollte einfach mal auch nach vielen Jahren DANKE sagen für Lösungen, die auch heute noch funktionieren Grin

@Heiner Lohaus schrieb:

Hi,

schaue mal in deine .php-Datei.
Dort müsste soetwas drin stehen:
* @ORM\Table(name="**_attributes")
Die dort genannte MySQL-Tabelle musst du löschen.

Dann dürfte die .php-Datei auch nicht mehr angelegt werden.

Gruß Heiner