Menu entry for plugin in administration is missing

Hey, I have a custom plugin which used to worked back in January; now I would like to use with the newest development build SW 6.4. My problem is that the navigation menu entry in the administration has gone missing. Actually, this problem also occurs with the official, two months-old bundle example (git, navigation configured here) when installing it on the latest development build.

So my questions are:

  1. Can one restore the menu entry by making some adaptations?
  2. If not, as a workaround for the time being: Can one deduce an URL from one’s plugin code which one can enter directly? My educated guesses lead nowhere…

I have the exact same problem.
The Plugin was installed in February but now the Menu Item for the Plugin is missing in the Administration.

The Problem only occurs in the Staging Environment (Shop is not live yet).
In the local setup everything works fine.

I already tried deactivate and activating the plugin.
This did not help. So i uninstalled and installed the Plugin again, but the Problem is not solved.
Even trying to get the URL from the local instance and directly calling it on the staging environment did not work.
I’m only getting an white screen without any errors in the dev console.

The JavaScript files for the Bundles are available and loaded in the Browser.
I compared the JavaScript files from staging and local and they are identical.
So i can’t figure out where the Problem is besides the different environments.

Has no one a Solution for this Problem?

Is your menu on „level 0“? Shopware changed the behaviour, now it is only possible the add menus to the second level.

Is it your plugin? Have you rebuild the administration for your plugin for your used shopware version?

When you update your shop sometimes you need to build the administration/storefront of your plugin.