In admin menu is not showing after generating bundle for administration in Shopware 6

I build a simple plugin and it works fine for the frontend, however, I am trying to create a new menu in admin but the menu isn’t visible even after running the administration build command in Shopware 6.

Here are the file and code:


import enGB from './snippet/en-GB.json';
import deDE from './snippet/de-DE.json';
const {Module} = Shopware;

Module.register('webbytroops-shopfinder', {
    type: 'plugin',
    name: 'WebbytroopsShopFinder',
    title: 'webbytroops-shopfinder.general.mainMenuItemGeneral',
    description: 'webbytroops-shopfinder.general.descriptionTextModule',
    version: '1.0.0',
    targetVersion: '1.0.0',
    color: '#9AA8B5',
    icon: 'default-shopping-paper-bag',
    snippets: {
        'de-DE': deDE,
        'en-GB': enGB
    navigation: [{
            id: 'wt-shopfinder',
            label: '',
            color: '#ff3d58',
            path: 'webbytroops.shopfinder.list',
            icon: 'default-shopping-paper-bag-product',
            position: 100


import './module/webbytroops-shopfinder';

Executed this command


Even tried with watch command as well


Can somebody help in finding the issue?


In the navigation entry you have to declare a parent, like sw-catalogue, sw-marketing,…

It is not allowed to add a navigation to the root element

I tried but with parent, it isn’t working. I provided parent sw-catalogue in meta but that isn’t working as well.

where exactly did you place the parent?

It’s showing in the backend under the existing submenu, earlier I was adding meta property for that because some tutorial showed that.
Why can’t we add a new root menu instead of putting it under the submenu?