<IfModule mod_deflate.c> in .htaccess

Hallo Community, ich wollte euch nur mal kurz mitteilen, dass der Eintrag # Enable gzip compression
AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json
so nicht bei jedem Hoster zu funktionieren scheint. Bei meinem Anbieter (Alfahosting) muss es so eingetragen werden:

SetOutputFilter DEFLATE

Was genau ist der Unterschied, oder ist es egal, wie es geschrieben wird? Gruß

[quote=„ffinkelm“]Hallo Community, ich wollte euch nur mal kurz mitteilen, dass der Eintrag # Enable gzip compression
AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json
so nicht bei jedem Hoster zu funktionieren scheint. Bei meinem Anbieter (Alfahosting) muss es so eingetragen werden:

SetOutputFilter DEFLATE

Was genau ist der Unterschied, oder ist es egal, wie es geschrieben wird? Gruß[/quote] Die erste Version schaut nach dem Mime-Type, die zweite schaut stumpf nach der Endung hinter dem Punkt. Wenn eine Datei nicht mit dem korrekten Mime-Type ausgeliefert wird, kann man dies über die Dateiendung erzwingen. Daher kommt auch die häufige Fehlermeldung bei PagespeedInsight, dass die CSS-Dateien nicht mit GZ komprimiert seien. Die haben den falschen Mime-type und dann funktioniert es nicht. Die Shopware htaccess so ergänzen, sollte bei den meisten Hostern ausreichen: # Enable gzip compression<ifmodule mod_deflate.c> AddType text/css .css AddType text/javascript .js AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json </ifmodule>

1 Like

Javascript wird bei mir nicht gzip-ped, ist das normal? Gzip compression ist aktiv. Gruß

Hallo, [quote=“ffinkelm”]Javascript wird bei mir nicht gzip-ped, ist das normal? Gzip compression ist aktiv. Gruß[/quote] wenn es um diese Seite geht, dann ist die Übertragung von JS- und CSS-Dateien mit gzip komprimiert. http://www.lille-sted.de

1 Like

Danke hth, scheinbar wieder ein Server Phänomen, oder aber der Eintrag in der .htaccess. Habe den Eintrag vor kurzem in der .htaccess noch mal geändert, diesmal scheint es richtig zu sein :slight_smile: Gruß