Link zu "Datenschutzbestimmungen" und "Versandkosten" funktioniert nicht

Hallo alle zusammen,

Wenn man im Footer links auf Kontaktformular klickt und im sich dann geöffneten Popup auf „Ich habe die Datenschutzbestimmungen zur Kenntnis genommen.“ funktioniert der Link zu Datenschutzbestimmungen nicht bzw. öffnet sich die entsprechende Seite nicht.

Desweiteren funktioniert auch nicht der Footer Link Versandkosten bei

„* Alle Preise inkl. gesetzl. Mehrwertsteuer zzgl. Versandkosten und ggf. Nachnahmegebühren, wenn nicht anders beschrieben“

In den Stammdaten haben wir die entsprechenden Zuweisungen selbstverständlich vorgenommen.

Ist der Bug bekannt?

Schick mal einen Link von deinem Shop, lokal mit der 6.1.1 kann ich das nicht nachvollziehen.

Hast du mal in die Textbausteine geschaut? Da müsste man dann den Link hinterlegen. Ein Mapping auf die Grundeinstellungen gibt es da noch nicht.

[@Moritz Naczenski](http://forum.shopware.com/profile/14574/Moritz Naczenski “Moritz Naczenski”)‍

Vielen Dank für Deine mal wieder sehr schnelle Antwort - ich bin begeistert!

Hier ist der Link zu einem Testshop von uns:
https://www.messserprofi.com/

Ich habe die Textbausteine NICHT editiert, da ich davon ausgegangen bin, dass das Mapping schon funktioniert! Das Mapping funktioniert ja auch bei den Links zu Kontaktformular , Widerrufsformular und AGB - OHNE das ich die Textbausteine editiert habe!!!

Der Textbaustein hat kein Mapping, da musst du es aktuell manuell eintragen.

Bei den anderen Links ist das entsprechend ins Theme eingebaut, dass das Mapping funktioniert. 

Habe dazu mal einen Verbesserungsvorschlag erstellt: Shopware Issuetracker

[@Moritz Naczenski](http://forum.shopware.com/profile/14574/Moritz Naczenski „Moritz Naczenski“)‍

danke, dass Du ein Ticket erstellt hat. In dem Ticket hast Du aber lediglich den fehlenden Link zu den Versandkosten erwähnt aber NICHT zu den Datenschutzbestimmungen. Es wäre super, wenn Du das Ticket entsprechend modifzieren würdest, dass das mit einem zeitnahen Update behoben wird.

Hallo zusammen,

habe das gleiche Problem. Welchen Link muss ich denn in den Textbausteinen einfügen? Wo kann ich denn den sehen?

Hallo.
Ich will das Thema noch mal hoch holen, da alle Antworten irgendwie nicht wirklich zu einem vernünftigem Ergebnis führen:
Die Datenschutzbestimmungen, Impressum, usw. wurden in den Shopeinstellungen mit dem dazugehorenden Theme versehen. Trotzdem funktionieren die Seiten mit den Links zu Datenschtz, Versandkosten, Impressum, usw nicht richtig. Dort erscheint immer diese Musterseite vom Shopware in der Modalbox .
Wenn ich das mit der vollen Domain zur z.B. Versandkostenseite verlinken möchte (https://www.meinedomain.de/Informationen/Versandkosten/), an welche Stelle muß jetzt der Link hinein?

* Alle Preise inkl. gesetzl. Mehrwertsteuer zzgl. <a data-url="%url%" href="%url%" data-toggle="modal">Versandkosten</a> und ggf. Nachnahmegebühren, wenn nicht anders angegeben.

Hier sind ja zwei URLs angegeben. Habe beide schon ersetzt mit dem Link, gibt aber nur Fehlermeldungen in Frontend.

Danke schon mal.

So, Stand der Dinge ist:
Der Datenschutz-Link ist ja in dem Textbaustein unter BASE de-DE general.privacyNotice zu finden.

Ich habe die <a title="Datenschutzerklärung" href="%url%" data-url="%url%" data-toggle="modal">Datenschutzbestimmungen</a> zur Kenntnis genommen.

Ich habe jetzt an verschiedenen Stellen versucht meinen Datenschutz-Link (https://www.meinedomain.de/Informationen/Datenschutz/) einzufügen, aber leider funktioniert es nicht.

Weiter ist es das Selbe bei dem Versandkosten-Link im Footer. Dieser wird in den Textbausteinen unter footer.includeVat veränderd.

* Alle Preise inkl. gesetzl. Mehrwertsteuer zzgl. <a data-url="%url%" href="%url%" data-toggle="modal">Versandkosten</a> und ggf. Nachnahmegebühren, wenn nicht anders angegeben.

Auch hier habe ich an verschiedenen Stellen versucht den kompletten Versandkosten-Link (https://www.meinedomain.de/Informationen/Versandkosten/) einzufügen, jedoch auch hier ohne Erfolg.

Wie bekommt man denn nun die verlinkten Kategorieseiten an den entsprechenden Stellen angezeigt…??

Hallo @Z3PP,

zunächst kann ich das ursprümgliche Verhlaten in der aktuellsten Shopware Version 6.4.2.1 nicht reproduzieren (auch ohne die Textbausteine anzupassen), ich habe hierzu testweise mal ein neues Layout angelegt und zugewiesen.

Wenn du nun simpel auf deine Kategorieseite (mit dem entsprechenden Layout) verlinken möchtest, musst du den Textbaustein folgendermaßen anpassen:

<a title="Datenschutzvereinbarung" href="DEINE_URL_AUF_DIE_VERLINKT_WERDEN_SOLL">Ich habe die Informationen zur Datenschutzvereinbarung gelesen.</a>

Dies öffnet die Seite dann nicht mehr in einem Modal sondern ruft direkt die Seite auf. Du könntest natürlich target="_blank" ergänzen um die Seite im neuen Tab öffnen zu lassen.

Ich hoffe das hilft dir weiter!

Viele Grüße aus Schöppingen
Florian Holtgrefe

Hallo Florian.
Vielen Dank für deine Hilfe und die Informationen.

Wenn ich bei mir in den Textbausteinen den URL-Link zum Datenschutz nehme, kommt bei mir genau da die Fehlermeldung.

Ich habe es jetzt anders gelöst. Entdeckung per Zufall :slight_smile:
Ich habe in den Kategorien (z.B.) Datenschutz das Theme „Datenschutz“ verwendet. Dort im Theme „Datenschutz“ habe ich den Lorsom…-Text geändert und den original Datenschutz-Text noch einmal hinein kopiert. Geht perfekt mit Modalbox.

Jetzt müßte ich nur noch die Modalbox etwas verbreitern, so auf DIN A4 Seite Breite.
Könnt Ihr mir da noch mal helfen, wo ich die Breite der Modalbox verändern kann…?

Grüße,
Achim

Das geht nur über das Theme wofür du ein Theme Plugin entwickeln müsstest, da es keine Konfiguration für die Modal Boxes gibt.

Leider funktioniert bei mir der Link zu den Datenschutzbestimmungen im Gegensatz zu den Versandkosten immer noch nicht automatisch. Muss dies noch irgendwo konfiguriert werden oder wieso muss es manuell angepasst werden?

Falls noch mal jemand darüber stolpert: Die Zuweisung einer Seite als Datenschutz geht (getestet mit 6.4.7.0) nicht im Theme, sondern über die Berabeitung des Layouts im Bereich Erlebniswelten. Dort das Modal Layout-Zuweisung aufrufen und den Reiter „Shopseiten“ aufrufen und im Select Datenschutzseiten auswählen. Von hinten durch die Brust ins Auge… :crazy_face:

Beste Grüße,
devnullroot

Das geht doch schon immer über Einstellungen > Stammdaten > Shopseiten > Shopseiten-Layout für Datenschutz-Seiten?! @devnullroot

Und genau das hat bei mir eben nicht funktioniert.

Jep,

@Max_Shop hat natürlich völlig Recht! Ich habe den Wald vor lauter Bäumen nicht gesehen und nur in den Einstellungen für den Theme Verkaufskanal geschaut. Mea culpa :upside_down_face:

@SmartStylez funktioniert es denn jetzt über die Stammdaten-Einstellungen?

Beste Grüße,
devnullroot

Ich habe den Link manuell angepasst, mit den Standardwerten hat es nicht automatisch geklappt.