Import/Export Profile ohne Namen & Fehlermeldung

Hallo, 

leider gibt es wieder mal Probleme mit Shopware 6. Sowohl in einer Testumgebung als auch in einer Neuinstallation werden keine Profilnamen beim Import/Export angezeigt. Wählt man trotzdem ein Profil aus, wird folgende Fehlermeldung ausgegeben:

0: Argument 1 passed to Shopware\Core\Content\ImportExport\Aggregate\ImportExportLog\ImportExportLogEntity::setProfileName() must be of the type string, null given, called in /var/www/clients/client1/web3/web/vendor/shopware/core/Content/ImportExport/Service/ImportExportService.php on line 245

Wie kann man das beheben und einen Produkt Export bzw. Import von einem SW6 System zum anderen durchführen?

Weiß hier jemand Bescheid? Immerhin handelt es sich ja um eine grundlegende Shop-Funktion in einer neuinstallierten Umgebung, daher ist es schon komisch, dass es nicht funktioniert

Bei mir das gleiche, gibs da schon eine Lösung?

Dito mit frischer Installation.

Dito

Habe das Problem letzte Woche an den Suport gemeldet

warte auf Antwort

Als Quickwin kann man das profil auf jeden Fall duplizieren, die fehlenden Felder hinzufügen und dann auch nutzen.

1 Like

Ich habe in einer Testumgebung das gleiche Problem.

Als eCommerce-Neuling probiere ich seit ein paar Wochen einige Shop-Lösungen aus. Von der Funktionalität finde ich SW6 eigentlich sehr gut, aber leider machen diverse kleine Fehler (wie der in diesem Thread) den Gesamteindruck und das Vertrauen zunichte.

 

2 Likes

@Moritz Naczenski schrieb:

Als Quickwin kann man das profil auf jeden Fall duplizieren, die fehlenden Felder hinzufügen und dann auch nutzen.

Leider geht auch das nicht, da auch bei den duplizierten Profilen kein Name gespeichert/angezeigt wird. Man erhält nur ein Dropdown Menü mit weiteren leeren Einträgen.

Beim Klicken auf Export erscheint dann wieder folgende Fehlermeldung:

0: Argument 1 passed to Shopware\Core\Content\ImportExport\Aggregate\ImportExportLog\ImportExportLogEntity::setProfileName() must be of the type string, null given, called in /var/www/clients/client1/web2/web/vendor/shopware/core/Content/ImportExport/Service/ImportExportService.php on line 245

@geraldo schrieb:

Dito

Habe das Problem letzte Woche an den Suport gemeldet

warte auf Antwort

Hallo, und was hat dieser gesagt? Oder gibt es ein Ticket im Issuetracker als Referenz?

Ich habe dasselbe Problem. Gibt es denn keine Lösung dafür?

Vielleicht hilft das ja anderen auch:

Ich habe die Sprache im Adminbereich auf Englisch gestellt und konnte dort den Namen des neuen Profils speichern.

Anschliessend funktionierte der Export auch.

Doch hatte pro Support und es wurde händisch in der Datenbank eingetragen

aber ich gebe wahrscheinlich auf

die Anzahl der bugs in der 6 machen keinen Sinn

evtl in 2Jahren ist es soweit

teste gerade wooc*

 

 

@OliverS schrieb:

@geraldo schrieb:

Dito

Habe das Problem letzte Woche an den Suport gemeldet

warte auf Antwort

Hallo, und was hat dieser gesagt? Oder gibt es ein Ticket im Issuetracker als Referenz?

 

Hallo, und was hat dieser gesagt? Oder gibt es ein Ticket im Issuetracker als Referenz?

An sich ist die Lösung hier beschrieben: https://forum.shopware.com/discussion/70616/geloest-import-export-profilnamen-fehlen

 

Irgendwie muss es ja mit Übersetzungen zu tun haben, das müsste Shopware doch eigentlich hinbekommen, finde aber kein entsprechendes Ticket im Issue-Tracker. Wer eins hat bitte gerne hier posten zur Nachverfolgung.

Habe nach einem anderen Hinweis die Sprache im Admin auf Englisch gestellt, dann ging es, und die Namen wurden nach Umstellung auf deutsch auch angezeigt

Ich hänge mich hier mal mit an. Egal was ich umstelle die Profile werden einfach nicht angezeigt.

LG Tom

Ich habe momentan das selbe Problem und der Link existiert leider nicht mehr. Wissen Sie noch, wie die Lösung beschrieben wird?

Hallo NicoHH,
der Thread mit der Lösung war dieser hier: https://forum.shopware.com/t/gelost-import-export-profilnamen-fehlen/68807/8.

Bei neueren Versionen als 6.3.2.1 oder 6.3.3.0 werden die fehlenden Profilnamen aber vermutlich andere Ursachen haben.