Composer failure during installation

i get these messages from composer

[ ! -f vendor/autoload.php ] || $PHP_BINARY bin/console system:update:prepare
PHP Warning: Unsupported declare ‚strict_types‘ in /home/user/www/shopware/bin/console on line 2
PHP Parse error: syntax error, unexpected ‚?‘ in /home/user/www/shopware/bin/console on line 37
Script [ ! -f vendor/autoload.php ] || $PHP_BINARY bin/console system:update:prepare handling the pre-install-cmd event returned with error code 255

Hello and welcome @nobanker,

for me, it looks like you either don’t run the appropriate PHP version on CLI or your system cache is not writable - just a wild guess :wink:

yes, that server had an old php
now i put php 7.4 but still have installation issues