Bearbeitung der config.php

hallo,

ich würde gerne in meiner config.php gerne gemäß Varnish Setup den reverse proxy mit dem zusatz

‘httpCache’ => array( ‘enabled’ => false, ),

deaktivieren.

aber ich bin laie und egal wie ich das einbaue, der shop zeigt dann eine 500 fehlermeldung. ich hoffe jemand kann mir helfen , so sieht meine config.php jetzt aus:

<?php
return array(     'db' =\> array(         'username' =\> 'xxxxxx',         'password' =\> 'xxxxxx',         'dbname' =\> 'xxxxxx',         'host' =\> 'xxxxxx',         'port' =\> 'xxxx'   grüße, bernd.

So wäre es richtig:

<?php return array ( 'db' =>    array (     'host' =\> 'localhost',     'port' =\> '3306',     'username' =\> 'xxx',     'password' =\> 'xxx',     'dbname' =\> 'xxx',   ), 'httpCache' =\> array( 'enabled' =\> false, ), ); Und ändere bitte dein Datenbank-Passwort.
1 Like

Besten Dank ! Hat jetzt funktioniert, aber leider nicht wie erhofft meinen Revese-Proxy- Fehler beseitigt.

Hast Du eine Vermutung woran das sonst leigen könnte ? :

Message:

 Reverse proxy returned invalid status code

Time:

 2017-01-06T12:56:13.332972+0100

Channel:

 core

Context:

 { "response": ""-//IETF//DTD HTML 2.0//EN\"\>\n\n<title>501 Method Not Implemented</title>\n\n
# Method Not Implemented
\n

BAN to /server.shtml not supported.  
\n

\n\n", "code": 501 }

request:

 { "uri": "/backend/Cache/clearDirect?cache=Config&\_dc=1483703770542", "method": "GET", "query": { "cache": "Config", "\_dc": "1483703770542", "module": "backend", "controller": "Cache", "action": "clearDirect" }, "post": [] }

shop:

 No shop data available

session:

 { "userId": "50", "roleId": "1" }

Naja, du hast den HTTP-Cache jetzt abgeschaltet, dass wäre eine ziemlich komische Lösung. Die Meldung ist ja erstmal nur ein Hinweis und keine Fehlermeldung, dadurch geht ja nix kaputt.

 

1 Like

ok, verstanden, danke.