Artikel erst nah nochmaligen speichern sichtbar

Hallo zusammen, wir haben das Problem, dass nach dem Aktivieren einer (zuvor deaktivierten) Kategorie keine der zugeordneten Artikel im Frontend sichtbar sind. Erst wenn wir einen betroffenen Artikel im Backend aufrufen und erneut speichern (ohne Änderungen vorzunehmen), ist dieser im Frontend wieder sichtbar. Da es sich um mehrere tausend Artikel handelt, ist das echt ein Problem. Hat vielleicht jemand eine Idee wie wir das beheben können bzw. woran das liegen kann? Vielen Dank schon mal!

habe nun herausgefunden, dass die Artikel in der Datenbank inaktiv sind (active=0)obwohl sie im Backend aktiv sind. Auch neu importierte Artikel betrifft dieses Problem.

Importiert Ihr die Artikel über die API? Schau mal ob in der Tabelle s_articles_details die kind active auf 1 steht. Das ist hierbei meistens der Fehler. Siehe auch hier: programmierung-f103/api-importierte-artikel-in-storefront-nicht-angezeigt-t27056.html#p118634 oder hier: programmierung-f103/artikel-sichtbarkeit-nach-api-import-t29687.html

Hallo kayyy, danke für die Antwort. stimmt, kind steht auf 1. Wir importieren über CSV-Import. Muss kind auf 0 stehen? Kann man das irgendwie beheben? Die Links helfen mir irgendwie nicht weiter. Es handelt sich nicht um Variantenartikel. Danke

sind denn die spalten active auch auf 1 gesetzt in s_article_details ? Nein Kind muss nicht auf 0 stehen. 1 sagt praktisch das es der Hauptartikel ist und 2 das es ein Kind Artikel ist, also eine Variante. 1 steht immer für true - also aktiv. 0 ist false.

nein die die Spalte active (1 Spalte) ist auf 0, obwohl im Backend der Artikel als Aktiv angezeigt wird.