senanasenana MemberComments: 240 Received thanks: 8 Member since: December 2012

Version 6.3.1.1

Bei Varainten ist bei mir die Funktion von Streichpreisen ohne Funktion. Es scheint so, als wäre das ein Bug, denn Wenn ich die Felder für den Streichpreis befülle, wird anders als bei normalen Artikeln nicht automatisch der Brutto oder Nettopreis gefüllt. Man muss das jeweils händisch füllen. In der Ausgabe im Frontend ist dann der Streichpreis auch nicht zu sehen (also bei der Variante) obwohl im Backend gesetzt.

Übersehe ich eventuell eine wichtige Einstellung?

 

Thx

Answers

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 9663 Received thanks: 2921 Member since: September 2013

    image

     

    Konnte ich so jetzt nicht nachvollziehen - Hast du vielleicht Erweiterte Preise definiert?

  • senanasenana MemberComments: 240 Received thanks: 8 edited October 1 Member since: December 2012

    Hallo Moritz,

    das ist merkwürdig. Ich habe schon festgestellt, dass die automatische Umrechnung von netto/brutto beim Streichpreis (Variante) nur dann funktioniert wenn man die Vererbung bei der Variante deaktiviert (eigentlich verlinkt das folgende auf ein Video, k.a. warum es als Bild angezeigt wird.). 
     

    https://imgur.com/N7hBlW5

    Allerdings bleibt bei mir dennoch die Anzeige im Frontend unverändert. 

    Gibt es denn irgendwelche weitere Abhängigkeiten zwischen Vater und Kind bei der Variante, um die Streichpreise am Kind anzuzeigen?

  • senanasenana MemberComments: 240 Received thanks: 8 Member since: December 2012

    Ah, Ergänzung:
    Tatsächlich habe ich in der erweiterten Preisansicht einen Eintrag. Was hat es damit auf sich?

  • senanasenana MemberComments: 240 Received thanks: 8 Member since: December 2012

    Hmm, das wird immer undurchsichtiger für mich.

    Wenn ich an der Variante die erweiterte Preisansicht nutze für Staffelpreise, dann wird kein Hauptpreis angezeigt:



    Ich verstehe da irgendwie die ganze Logik wohl nicht. 

  • caprisnacaprisna MemberComments: 1 Received thanks: 0 Member since: October 18

    Hallo,

    konnte dasselbe Problem bei mir ebenfalls beobachten.
    Verwende ebenfalls die Version 6.3.1.1.

    Habe es dann mit einem neuen Produkt versucht. Nur die Pflichtfelder ausgefüllt und das Produkt einer Kategorie zugeordnet
    Ich konnte wie erwartet die Streichpreise sehen.

    Anschließend habe ich dann 3 Varianten mit jeweils einer Preisabweichung erstellt, die Streichpreise im Backend eingepflegt und es waren sowohl beim Hauptprodukt als auch bei den Varianten die Streichpreise in der UI nicht zu sehen.


    Nein, ich habe kein erweiterten Preise hinterlegt.

    Also vielleicht doch ein Bug ?!?

    Danke!

  • annacontaannaconta MemberComments: 511 Received thanks: 67 Member since: February 13
  • mattsbgmattsbg MemberComments: 5 Received thanks: 2 Member since: March 29

    Hallo,

    auch ich kann das Phänomen von caprisna bestätigen - Shopware 6.3.2.1. Sobald die Varianten unterschiedliche Preise haben, scheint dies der Grund dafür zu sein, dass es nicht funktioniert.

    Ich habe bei einem Testartikel auch die Situtation dass der Streichpreis bei 3 von 5 Varianten angezeigt wurde obwohl sie das idente Preisobjekt (kopiert über die Datenbank) hatten und nur das Hauptprodukt einen anderen Preis hatte.

    Lg,

    Matthias

  • mattsbgmattsbg MemberComments: 5 Received thanks: 2 Member since: March 29

    Hi, hier noch der Eintrag aus dem Issuestracker der das Problem aus meiner Sicht gut beschreibt: https://issues.shopware.com/issues/NEXT-11089

    lg, Matthias

    Thanked by 1opalion
Sign In or Register to comment.