MrFroxMrFrox MemberComments: 42 Received thanks: 1 Member since: April 8 edited August 11

Ich habe einen Shop, der einwandfrei mit SW-Version 5.5.10 auf meinem Server mit PHP-Version 7.0 und ionCube läuft. Ich habe eine Weitere Domain registriert, weil ich einen weiteren Shop haben möchte. Auch um mir SW6 mal anzusehen, möchte ich  dies nun installieren. Grundvoraussetzung ist die Verwendung von PHP-Verison 7.2. Ich habe nun alles installiert, mir ionCube für php7.2 heruntergeladen und die php-ini für 7.2 entsprechend eingestellt. stelle ich dann das System auf php7.2 um...

root@www2:/# a2enmod php7.2
Considering dependency mpm_prefork for php7.2:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php7.2:
Enabling module php7.2.
To activate the new configuration, you need to run:
  service apache2 restart
root@www2:/# a2dismod php7.0
Module php7.0 disabled.
To activate the new configuration, you need to run:
  service apache2 restart
root@www2:/# php -v
PHP 7.2.21-1+0~20190807.25+debian9~1.gbp935ebf (cli) (built: Aug  7 2019 19:49:58) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with the ionCube PHP Loader + ionCube24 v10.3.7, Copyright (c) 2002-2019, by ionCube Ltd.
    with Zend OPcache v7.2.21-1+0~20190807.25+debian9~1.gbp935ebf, Copyright (c) 1999-2018, by Zend Technologies

...sieht man, dass eigentlich alles soweit funktioniert. Auch ionCube ist geladen. Gehe ich nun zur In-Browser Installation von SW6, hat sich die Meldung...

Fehler
Auf Ihrem Server läuft PHP version 7.0.33-10+0~20190807.18+debian9~1.gbp5452d8, Shopware 6 benötigt mindestens PHP 7.2.0.
Error
Your server is running PHP version 7.0.33-10+0~20190807.18+debian9~1.gbp5452d8 but Shopware 6 requires at least PHP 7.2.0.

...verwandelt in den erwarteten Installations-Dialog. Es scheint alles cool zu sein. Allerdings funktioniert nun mein Alter SW5.5.10 Shop nicht mehr. Er gibt einen Error 500 im Browser zurück.

Hat jemand einen Tipp was ich hier tun kann, um das Problem zu lösen? Ich möchte beide Shops betreiben.

ps: Bevor ich ionCube in php7.2 integriert hatte, ging der alte SW5.5.10 Shop nach dem Uschalten auch schon nicht mehr, da wurde dann aber gemeckert, dass ionCube nicht gefunden wurde. Erst nach der entsprechenden Integration kommt nun der Error 500.

Answers

  • MrFroxMrFrox MemberComments: 42 Received thanks: 1 edited August 11 Member since: April 8

    In meinem Apache2-Serverlog steht drin:

    [Sun Aug 11 15:48:25.484088 2019] [php7:error] [pid 20108] [client 2003:ca:5718:9f00:8105:9ff9:d408:8749:52754] PHP Fatal error:  The file /var/www/shopware/engine/Shopware/Plugins/Community/Core/SwagLicense/Bootstrap.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.\n Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1. in Unknown on line 0

    Der Lizenz Manager ist auch neu installiert:

    image

    Also das ist auf jeden Fall der Fehler, aber wie bekommt man das auf die Reihe?

  • axGRuN5EwXNPzsaxGRuN5EwXNPzs MemberComments: 9 Received thanks: 0 Member since: November 2016

    Zum Testen von Shopware 6 würde ich auf jeden Fall eine getrennte Umgebung nutzen. Wenn Du dich allerdings genug auskennst dann solltest Du auch schnell herausfinden können warum Shopware 6 sagt, daß php 7.0 aktiv ist - das denkt der sich ja nicht irgendwie aus..

     

  • MrFroxMrFrox MemberComments: 42 Received thanks: 1 Member since: April 8

    @axGRuN5EwXNPzs‍ Sorry, ich glaube, du hast nicht richtig gelesen. Das ist nicht das Problem. Ich würde mich freuen, wenn du nochmal oben schaust :)

  • kullikulli MemberComments: 1873 Received thanks: 277 Member since: August 2013
  • drakondrakon MemberComments: 962 Received thanks: 268 Member since: February 2014

    Für verschlüsselte Plugins und/oder den Lizenzmanager funktioniert die Ioncube-Verschlüsselung nicht mit PHP > 7.0 bei Shopware.

  • MrFroxMrFrox MemberComments: 42 Received thanks: 1 edited August 11 Member since: April 8

    @drakon‍ oh, das steht also so fest. Verstehe! :/

    @kulli‍ ok, dann versche ich das. Ich hoffe, das führt nicht zu Problemen.

    Edit: ich habe den Lizenz-Manager im Backend deinstalliert. Nun kann ich, wenn ich wieder zu php7.2 switche, weiterhin weiterhin mein SW5.5.10 Backend nutzen, allerdings bringt mein Frontend wieder einn Error 500. Ich habe wieder in mein Error-Log auf dem Server geschaut und musste Feststellen, dass ich mehrere Fehlermeldungen verschiedenster Plugins habe, die auch alle mit ionCube verschlüsselt sind. Das gleiche Problem also wieder. Die kann ich abr nicht einfach alle deinstallieren, weil sie wichtig für meinen Shop sind ... :/

  • drakondrakon MemberComments: 962 Received thanks: 268 Member since: February 2014

    Über Plugin-Manager/Mein Einkäufe noch mal runter laden. Dann werden die unverschlüsselten Plugins geladen, sofern das Plugin jeweils für SW 5.5 frei gegeben ist.

Sign In or Register to comment.