neuling2016neuling2016 MemberComments: 11 Received thanks: 0 Member since: September 2016

Hallo,

mir ist folgendes aufgefallen:

-> Führe ich eine Bestellung als Kunde aus, wird mir in der sOrder Mail am Ende die MwSt. nach Steuersatz aufgeschlüsselt
-> Führe ich eine Bestellung über das Backend aus, wird die MwSt. nicht nach Steuersatz aufgeschlüsselt. 

Ich beziehe ich mich auf diesen Abschnitt der sOrder Mail:

Versandkosten: {$sShippingCosts|currency}<br/>
Gesamtkosten Netto: {$sAmountNet|currency}<br/>
{if !$sNet}
{foreach $sTaxRates as $rate => $value}
zzgl. {$rate|number_format:0}% MwSt. {$value|currency}<br/>
{/foreach}
<strong>Gesamtkosten Brutto: {$sAmount|currency}</strong><br/>

Hat hier jemand eine Idee? Würde das wirklich benötigen. Getestet in einer frischen 5.5.4 Installation.

Danke!

Answers

  • xanilyxanily MemberComments: 1 Received thanks: 0 edited July 18 Member since: July 18

    Der Beitrag ist zwar schon ein paar Monate her, aber ich habe auch das selbe Problem.

    Wenn eine Bestellung im Backend erstellt und die Bestätigungsmail versendet wird, erscheint in der E-Mail nicht die enthaltene Mehrwertsteuer.
    Wenn ich eine Bestellung ganz normal im Frontend erstelle, wird in der E-Mail die enthaltene Mehrwertsteuer angezeigt.

    Bei mir sieht die verwendete Lösung so aus:

    Enthaltene MwSt.: {if !$sNet}{foreach $sTaxRates as $rate => $value}{$rate|number_format:0}% MwSt.: {$value|currency|unescape:"htmlall"} {/foreach} {else}{/if}

    Leider habe ich auch noch keine Lösung gefunden, um dieses Problem zu lösen.
    Gibt es noch weitere, die dieses Problem ebenfalls haben?
     

    Getestet wurde es in der Shopware Version 5.5.7

Sign In or Register to comment.