Wo finde ich meine Shopware Datein? - Vagrant

Hallo,

hab heute zum ersten mal SW6 per Vagrant lokal installiert. Wo genau finde ich jetzt zb. mein frisch erstelltes Theme, welches ich per Konsole erstellt habe?

Will ein paar sachen an den CSS datein ändern.

Danke !

Im vendor/shopware findest du komplett Shopware installiert. Alle Änderungen die du machen kannst / willst solltest du über den “custom” Order lösen. Themes, plugins oder Anpassungen.

Dein frisch erstelltes Theme, sollte auch in dem custom/plugin Order drin sein, sofern es ein eigenes ist. Da ist die Dokumentation sehr hilfreich: https://docs.shopware.com/en/shopware-platform-dev-en/internals/storefront

1 Like

@CallMeAlex schrieb:

Im vendor/shopware findest du komplett Shopware installiert. Alle Änderungen die du machen kannst / willst solltest du über den “custom” Order lösen. Themes, plugins oder Anpassungen.

Dein frisch erstelltes Theme, sollte auch in dem custom/plugin Order drin sein, sofern es ein eigenes ist. Da ist die Dokumentation sehr hilfreich: https://docs.shopware.com/en/shopware-platform-dev-en/internals/storefront

Danke erstmal,

soweit weiß ich auch schon bescheid. Nur eben diese Ordner lassen sich nicht auf meinem System finden.

Ich arbeite mit Vagrant + Virtualbox auf einem Windows System.

@sunfield schrieb:

@CallMeAlex schrieb:

Im vendor/shopware findest du komplett Shopware installiert. Alle Änderungen die du machen kannst / willst solltest du über den “custom” Order lösen. Themes, plugins oder Anpassungen.

Dein frisch erstelltes Theme, sollte auch in dem custom/plugin Order drin sein, sofern es ein eigenes ist. Da ist die Dokumentation sehr hilfreich: https://docs.shopware.com/en/shopware-platform-dev-en/internals/storefront

Danke erstmal,

soweit weiß ich auch schon bescheid. Nur eben diese Ordner lassen sich nicht auf meinem System finden.

Ich arbeite mit Vagrant + Virtualbox auf einem Windows System.

Findest du die Ordner wenn du mit vagrant ssh in dein System gehst? Zeig notfalls mal deine Vagrant Datei. 

@CallMeAlex schrieb:

@sunfield schrieb:

@CallMeAlex schrieb:

Im vendor/shopware findest du komplett Shopware installiert. Alle Änderungen die du machen kannst / willst solltest du über den „custom“ Order lösen. Themes, plugins oder Anpassungen.

Dein frisch erstelltes Theme, sollte auch in dem custom/plugin Order drin sein, sofern es ein eigenes ist. Da ist die Dokumentation sehr hilfreich: https://docs.shopware.com/en/shopware-platform-dev-en/internals/storefront

Danke erstmal,

soweit weiß ich auch schon bescheid. Nur eben diese Ordner lassen sich nicht auf meinem System finden.

Ich arbeite mit Vagrant + Virtualbox auf einem Windows System.

Findest du die Ordner wenn du mit vagrant ssh in dein System gehst? Zeig notfalls mal deine Vagrant Datei. 

Ja, SSH alles kein Problem.  Mein Problem ist nur die Ordner auf meinem System zu finden wo die SW6 Datein sind. Per Systemsuche finde ich sie auch nicht.

Shopware ist unter /vendor/shopware zu finden.

@Moritz Naczenski schrieb:

Shopware ist unter /vendor/shopware zu finden.

Stand ja auch in der ersten Antwort. Ich glaube eher, es liegt an der Sync mit Vagrant.

config.vm.synced_folder "./", "/var/www", :nfs => !Vagrant::Util::Platform.windows?

Würde mal schauen @sunfield ob das in deiner Vagrantfile ist, damit dein Ordner auch gesynced wird. Sollte dann im gleichen Ordner wie die Vagrantfile sein. 

@CallMeAlex schrieb:

@Moritz Naczenski schrieb:

Shopware ist unter /vendor/shopware zu finden.

Stand ja auch in der ersten Antwort. Ich glaube eher, es liegt an der Sync mit Vagrant.

config.vm.synced_folder “./”, “/var/www”, :nfs => !Vagrant::Util::Platform.windows?

Würde mal schauen @sunfield ob das in deiner Vagrantfile ist, damit dein Ordner auch gesynced wird. Sollte dann im gleichen Ordner wie die Vagrantfile sein. 

Nein, steht dort nicht drinne.

hier meine Vagrantfile : # -*- mode: ruby -*-# vi: set ft=ruby :$pre_provision_update = <<-SCRIPT - Pastebin.com

hier mein Projekt Ordner: https://i.imgur.com/sofyKxr.png

@sunfield schrieb:

@CallMeAlex schrieb:

@Moritz Naczenski schrieb:

Shopware ist unter /vendor/shopware zu finden.

Stand ja auch in der ersten Antwort. Ich glaube eher, es liegt an der Sync mit Vagrant.

config.vm.synced_folder “./”, “/var/www”, :nfs => !Vagrant::Util::Platform.windows?

Würde mal schauen @sunfield ob das in deiner Vagrantfile ist, damit dein Ordner auch gesynced wird. Sollte dann im gleichen Ordner wie die Vagrantfile sein. 

Nein, steht dort nicht drinne.

hier meine Vagrantfile :

 

hier mein Projekt Ordner:

 

Dann füge das mal ein (Ich würde es Zeile 32 einfügen) und provisioniere Vagrant danach neu.

1 Like

@CallMeAlex schrieb:

@sunfield schrieb:

@CallMeAlex schrieb:

@Moritz Naczenski schrieb:

Shopware ist unter /vendor/shopware zu finden.

Stand ja auch in der ersten Antwort. Ich glaube eher, es liegt an der Sync mit Vagrant.

config.vm.synced_folder “./”, “/var/www”, :nfs => !Vagrant::Util::Platform.windows?

Würde mal schauen @sunfield ob das in deiner Vagrantfile ist, damit dein Ordner auch gesynced wird. Sollte dann im gleichen Ordner wie die Vagrantfile sein. 

Nein, steht dort nicht drinne.

hier meine Vagrantfile :

 

hier mein Projekt Ordner:

 

Dann füge das mal ein (Ich würde es Zeile 32 einfügen) und provisioniere Vagrant danach neu.

 Alles klar, das hat soweit geklappt. Nun habe ich einen “HTML” ordner wie üblich bei einem Webserver. Dieser ist nur leider nun leer?

LG

@sunfield schrieb:

@CallMeAlex schrieb:

@sunfield schrieb:

@CallMeAlex schrieb:

@Moritz Naczenski schrieb:

Shopware ist unter /vendor/shopware zu finden.

Stand ja auch in der ersten Antwort. Ich glaube eher, es liegt an der Sync mit Vagrant.

config.vm.synced_folder “./”, “/var/www”, :nfs => !Vagrant::Util::Platform.windows?

Würde mal schauen @sunfield ob das in deiner Vagrantfile ist, damit dein Ordner auch gesynced wird. Sollte dann im gleichen Ordner wie die Vagrantfile sein. 

Nein, steht dort nicht drinne.

hier meine Vagrantfile :

 

hier mein Projekt Ordner:

 

Dann füge das mal ein (Ich würde es Zeile 32 einfügen) und provisioniere Vagrant danach neu.

 Alles klar, das hat soweit geklappt. Nun habe ich einen “HTML” ordner wie üblich bei einem Webserver. Dieser ist nur leider nun leer?

LG

Vergessen zu sagen, unter vagrant ssh sind deine Dateien da sagtest du? Dann muss du in der Vagrant config anstatt “/var/www” natürlich den Pfad deiner Installation angeben. Damit synced er den vagrant Ordner in deinen “./” localen wo die config zu finden ist.

 

Grüße

1 Like

Hallo Leute,

leider habe ich das selbe Problem wie @sunfield‍, kann vagrant jedoch nicht neu provisionieren. Meine vagrantfile sieht folgendermaßen aus: 

# -*- mode: ruby -*-
# vi: set ft=ruby :

$pre_provision_update = < !Vagrant::Util::Platform.windows?
end

Sobald ich in git bash vagrant provision eingebe erhalte ich folgende fehlermeldung: 

TASK [clone shopware-dev git repo] *********************************************
fatal: [default]: FAILED! => {“before”: “fd2c7ff0a0769650b36737f3a9524e2bd3823e5d”, “changed”: false, “msg”: “Local modifications exist in repository (force=no).”}

Würde mich sehr freuen wenn mich jemand aufklären könnte! 

Grüße

@DavidH schrieb:

Hallo Leute,

leider habe ich das selbe Problem wie @sunfield‍, kann vagrant jedoch nicht neu provisionieren. Meine vagrantfile sieht folgendermaßen aus: 

-- mode: ruby --

vi: set ft=ruby :

$pre_provision_update = < !Vagrant::Util::Platform.windows?
end

Sobald ich in git bash vagrant provision eingebe erhalte ich folgende fehlermeldung: 

TASK [clone shopware-dev git repo] *********************************************
fatal: [default]: FAILED! => {“before”: “fd2c7ff0a0769650b36737f3a9524e2bd3823e5d”, “changed”: false, “msg”: “Local modifications exist in repository (force=no).”}

Würde mich sehr freuen wenn mich jemand aufklären könnte! 

Grüße

Ich habe leider das selbe Problem. Ich verstehe nicht ganz, welchen Pfad ich angeben muss und wie ich es herausfinde. Ich bin 1:1 den Schritten in der offiziellen Anleitung gefolgt. Es wäre super, wenn uns jemand vielleicht helfen könnte :slight_smile:

@Michal schrieb:

@DavidH schrieb:

Hallo Leute,

leider habe ich das selbe Problem wie @sunfield‍, kann vagrant jedoch nicht neu provisionieren. Meine vagrantfile sieht folgendermaßen aus: 

-- mode: ruby --

vi: set ft=ruby :

$pre_provision_update = < !Vagrant::Util::Platform.windows?
end

Sobald ich in git bash vagrant provision eingebe erhalte ich folgende fehlermeldung: 

TASK [clone shopware-dev git repo] *********************************************
fatal: [default]: FAILED! => {“before”: “fd2c7ff0a0769650b36737f3a9524e2bd3823e5d”, “changed”: false, “msg”: “Local modifications exist in repository (force=no).”}

Würde mich sehr freuen wenn mich jemand aufklären könnte! 

Grüße

Ich habe leider das selbe Problem. Ich verstehe nicht ganz, welchen Pfad ich angeben muss und wie ich es herausfinde. Ich bin 1:1 den Schritten in der offiziellen Anleitung gefolgt. Es wäre super, wenn uns jemand vielleicht helfen könnte :slight_smile:

Für den Fehler hat es mir geholfen mit vagrant ssh eine Verbindung aufzubauen und anschließen im shopware-dev Ordner einmal alles löschen und git reset --hard

Danach lief das provisioning durch