Weiterleitung klappt nicht richtig :(( zahle als Dankeschön 20€ Paysafecard

Hallo leute, die Weiterleitung klappt auf meinem shop nicht richtig.

Problem 1)

Wenn ich: http://online-haus24.de/agb oder online-haus24.de/agb eintippe werde ich auf die Startseite geleitet und nicht zu den AGBs

Aber wenn ich: https://online-haus24.de/agb https://www.online-haus24.de/agb http:/www.online-haus24.de/agb und www.online-haus24.de/agb eingebe klappt es, also werde ich auf die AGBs weitergeleitet…

 

Problem 2)

Hab SSL aktiviert aber so richtig will es nicht klappen, wenn ich die Links ohne https:// aufrufe wird nicht angezeigt das ich SSL aktiviert habe.

Aber wenn ich die Seite mit https:// aufrufe, oder wenn ich mich auf der Seite schon befinde und irgendwo hinklicke klappt es mit dem SSL.

 

Kann mir jemand helfen ?

Wäre euch sehr Dankbar.

Hi,

je nachdem was du für einen Server hast musst du deine .htaccess oder nginx Regeln anpassen. 

VG

Leite in der .htaccess einfach alle Anfragen ohne http: auf https: weiter. Die Domain sollte über http gar nicht mehr aufgerufen werden können.

 RewriteCond %{HTTPS} !=on RewriteRule (.\*) https://%{HTTP\_HOST}%{REQUEST\_URI} [L,R=301]

 

@shocki schrieb:

Leite in der .htaccess einfach alle Anfragen ohne http: auf https: weiter. Die Domain sollte über http gar nicht mehr aufgerufen werden können.

RewriteCond %{HTTPS} !=on RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

 

Habe ich gemacht, jetzt krieg ich einen Umleitungsfehler.

 



RewriteEngine on

RewriteCond %{HTTPS} !=on

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteBase /

Https config for the backend

#RewriteCond %{HTTPS} !=on
#RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule backend/media/(.*) media/$1 [NC,L]

RewriteCond %{REQUEST_URI} !(/(engine|files|templates|themes|web)/)
RewriteCond %{REQUEST_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

Fix missing authorization-header on fast_cgi installations

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]



# Block access to VCS directories

RedirectMatch 404 /\.(svn|git|hg|bzr|cvs)(/|$)

    # Restrict access to root folder files
    RedirectMatch 404 /(composer.(json|lock)|README.md|UPGRADE.md)$

Staging environment

#SetEnvIf Host „staging.test.shopware.in“ SHOPWARE_ENV=staging

Development environment

#SetEnvIf Host „dev.shopware.in“ SHOPWARE_ENV=dev
#SetEnv SHOPWARE_ENV dev

DirectoryIndex index.html
DirectoryIndex index.php
DirectoryIndex shopware.php

Disables download of configuration



# Deny all requests from Apache 2.4+.



Require all denied

    # Deny all requests from Apache 2.0-2.2.
   

Deny from all

Enable gzip compression



AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json





ExpiresActive on

ExpiresDefault „access plus 1 month“

   

Header append Cache-Control „public“

Header unset ETag

    FileETag None

Match generated files like:

1429684458_t22_s1.css

1429684458_t22_s1.js





Header set Cache-Control „max-age=31536000, public“

   

ExpiresActive on

ExpiresDefault „access plus 1 year“

Disables auto directory index



Options -Indexes



Options -MultiViews


php_value memory_limit 256M

php_value max_execution_time 120

php_value upload_max_filesize 20M

php_flag phar.readonly off

php_flag magic_quotes_gpc off

php_flag session.auto_start off

php_flag suhosin.session.cryptua off

php_flag zend.ze1_compatibility_mode off

php_value always_populate_raw_post_data -1

#   AddType x-mapp-php5 .php
#   AddHandler x-mapp-php5 .php



Header append X-Frame-Options SAMEORIGIN

RewriteBase /
RewriteCond %{HTTP_HOST} !^www.online-haus24.de$ [NC,OR]
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://www.online-haus24.de/$1 [R=301,L]

@megadruck schrieb:

RewriteBase /
RewriteCond %{HTTP_HOST} !^www.online-haus24.de$ [NC,OR]
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://www.online-haus24.de/$1 [R=301,L]

Immer noch Umleitungsfehler

 



RewriteEngine on

RewriteBase /
RewriteCond %{HTTP_HOST} !^www.online-haus24.de$ [NC,OR]
RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://www.online-haus24.de/$1 [R=301,L]

Https config for the backend

#RewriteCond %{HTTPS} !=on
#RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule backend/media/(.*) media/$1 [NC,L]

RewriteCond %{REQUEST_URI} !(/(engine|files|templates|themes|web)/)
RewriteCond %{REQUEST_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

Fix missing authorization-header on fast_cgi installations

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]



# Block access to VCS directories

RedirectMatch 404 /\.(svn|git|hg|bzr|cvs)(/|$)

    # Restrict access to root folder files
    RedirectMatch 404 /(composer.(json|lock)|README.md|UPGRADE.md)$

Staging environment

#SetEnvIf Host “staging.test.shopware.in” SHOPWARE_ENV=staging

Development environment

#SetEnvIf Host “dev.shopware.in” SHOPWARE_ENV=dev
#SetEnv SHOPWARE_ENV dev

DirectoryIndex index.html
DirectoryIndex index.php
DirectoryIndex shopware.php

Disables download of configuration



# Deny all requests from Apache 2.4+.



Require all denied

    # Deny all requests from Apache 2.0-2.2.
   

Deny from all

Enable gzip compression



AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json





ExpiresActive on

ExpiresDefault “access plus 1 month”

   

Header append Cache-Control “public”

Header unset ETag

    FileETag None

Match generated files like:

1429684458_t22_s1.css

1429684458_t22_s1.js





Header set Cache-Control “max-age=31536000, public”

   

ExpiresActive on

ExpiresDefault “access plus 1 year”

Disables auto directory index



Options -Indexes



Options -MultiViews


php_value memory_limit 256M

php_value max_execution_time 120

php_value upload_max_filesize 20M

php_flag phar.readonly off

php_flag magic_quotes_gpc off

php_flag session.auto_start off

php_flag suhosin.session.cryptua off

php_flag zend.ze1_compatibility_mode off

php_value always_populate_raw_post_data -1

#   AddType x-mapp-php5 .php
#   AddHandler x-mapp-php5 .php



Header append X-Frame-Options SAMEORIGIN

 

Dann schau doch mal bitte im error_log nach oder wenn nicht aufschlussreich im access_log. was der apache genau versucht aufzurufen

@megadruck schrieb:

Dann schau doch mal bitte im error_log nach oder wenn nicht aufschlussreich im access_log. was der apache genau versucht aufzurufen

sorry aber wo befinden die sich ?

Das ist unterschiedlich, je nach Provider.

Hast Du einen eigenen Server mit vollen Root Rechten dann schau unter /var/log/apache zb.

Oder in Deinem Document_Root bzw einen drunter. Schau da mal nach dem Ordner logs.

 

Welcher Provider ist das ?

 

Mir fällt noch ein. ist Shopware auf https konfiguriert ? Der macht sonst bestimmt wieder ne Rückumleitung auf http und dann greift htaccess wieder.

Ist jetzt ne Vermutung. Selber habe ich nur einen Testshop und noch kein SSL

Grundeinstellugne->Shopeinstellungen ->Shops->SSL verwenden

@megadruck schrieb:

Das ist unterschiedlich, je nach Provider.

Hast Du einen eigenen Server mit vollen Root Rechten dann schau unter /var/log/apache zb.

Oder in Deinem Document_Root bzw einen drunter. Schau da mal nach dem Ordner logs.

 

Welcher Provider ist das ?

 

bin bei Mittwald

Und ja ich habe bei den Einstellungen - Shop SSL aktiviert.

Bei mittwald ist das access_log im root ordner /logs

Kommste per FTP direkt drauf

1 Like

Ich würde mir jetzt deswegen keinen Stress machen am Sonntag abend. Machs über http und ruf morgen Mittwald an, wenn Du die logs nicht findest.

@megadruck schrieb:

Bei mittwald ist das access_log im root ordner /logs

Kommste per FTP direkt drauf

198.41.242.24 - - [02/Apr/2017:19:45:48 +0200] “GET / HTTP/1.1” 301 492 “-” “Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0” www.online-haus24.de
198.41.242.24 - - [02/Apr/2017:19:45:48 +0200] “GET / HTTP/1.1” 301 492 “-” “Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0” www.online-haus24.de
198.41.242.24 - - [02/Apr/2017:19:45:48 +0200] “GET / HTTP/1.1” 301 492 “-” “Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0” www.online-haus24.de
198.41.242.24 - - [02/Apr/2017:19:45:48 +0200] “GET / HTTP/1.1” 301 492 “-” “Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0” www.online-haus24.de
198.41.242.24 - - [02/Apr/2017:19:45:48 +0200] “GET / HTTP/1.1” 301 492 “-” “Mozilla/5.0 (Windows NT 6.1; rv:52.0) Gecko/20100101 Firefox/52.0” www.online-haus24.de 

Weiß nicht wirklich wo der Fehler liegt…

Kann das sein dass die Seite per http aufgerufen wird und nicht per https ?
Und wie änder ich das nun ?

Schau mal hier im unteren Bereich

 

Danahc müsste es so aussehen

 

RewriteBase /
RewriteCond %{HTTP_HOST} !^www.online-haus24.de$ [NC,OR]
RewriteCond %{SERVER_PORT} ^80$
RewriteRule ^(.*)$ https://www.online-haus24.de/$1 [R=301,L]

@megadruck schrieb:

Schau mal hier im unteren Bereich

https://gist.github.com/alrnz/b23f1384dd4def9ca054

Was soll ich machen ? die im htacces eintragen ?

Ansonsten ,muss ich jetzt hier aus der Ferne passen. Warte sonst bis morgen und lass es über http laufen solange

das :slight_smile:

RewriteBase /
RewriteCond %{HTTP_HOST} !^www.online-haus24.de$ [NC,OR]
RewriteCond %{SERVER_PORT} ^80$
RewriteRule ^(.*)$ https://www.online-haus24.de/$1 [R=301,L]

1 Like

Hast Du es denn bei den Shopware Einstellung korrekt konfiguriert ? „SSL verwenden“ und „SSL überall verwenden“ ? 

 

@megadruck schrieb:

das :slight_smile:

RewriteBase /
RewriteCond %{HTTP_HOST} !^www.online-haus24.de$ [NC,OR]
RewriteCond %{SERVER_PORT} ^80$
RewriteRule ^(.*)$ https://www.online-haus24.de/$1 [R=301,L]

Nee klappt nicht…

vielleicht sollte ich erwähnen das ich das SSL von Cloudflare beziehe nicht von Mittwald.