Update auf 6.6.0.2

Oder anders ausgedrückt:

th

ebenfalls ein error

Run Update preparations
> pre-update-cmd: Symfony\Flex\Flex->configureInstaller
Loading composer repositories with package information
> pre-pool-create: Symfony\Flex\Flex->truncatePackages
Updating dependencies
Dependency resolution completed in 0.000 seconds
Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires shopware/core 6.6.0.2 -> satisfiable by shopware/core[v6.6.0.2].
    - shopware/core v6.6.0.2 requires symfony/stopwatch ~7.0.0 -> found symfony/stopwatch[v7.0.0, v7.0.3] but it conflicts with your root composer.json require (^5.0|^6.0).
  Problem 2
    - shopware/core v6.6.0.2 requires symfony/stopwatch ~7.0.0 -> found symfony/stopwatch[v7.0.0, v7.0.3] but it conflicts with your root composer.json require (^5.0|^6.0).
    - shopware/storefront v6.6.0.2 requires shopware/core v6.6.0.2 -> satisfiable by shopware/core[v6.6.0.2].
    - Root composer.json requires shopware/storefront 6.6.0.2 -> satisfiable by shopware/storefront[v6.6.0.2].

Use the option --with-all-dependencies (-W) to allow upgrades, downgrades and removals for packages currently locked to specific versions.


von 6.5.8.7 auf 6.6.0.2

1 Like

Das Update bricht ohne echte Fehlermeldung ab. Nachfolgend das Ende der log.txt. Im ganzen log ist keine Fehlermeldung enthalten.

  Enabling the package as a Symfony bundle
    Copying files from recipe
      Created "./config/packages/dev/monolog.yaml"
      Created "./config/packages/prod/deprecations.yaml"
      Created "./config/packages/prod/monolog.yaml"
      Created "./config/packages/test/monolog.yaml"
  - Configuring symfony/routing (>=5.4): From github.com/shopware/recipes:main
  - Configuring symfony/translation (>=5.4): From github.com/shopware/recipes:main
  - Configuring symfony/twig-bundle (>=5.4): From github.com/shopware/recipes:main
    Enabling the package as a Symfony bundle
  - Configuring symfony/validator (>=7.0): From github.com/symfony/recipes:main
    Copying files from recipe
      Created "./config/packages/validator.yaml"
  - Configuring phpunit/phpunit (>=9.6): From github.com/symfony/recipes:main
    Copying files from recipe
      Created "./.env.test"
      Created "./phpunit.xml.dist"
      Created "./tests/bootstrap.php"
    Adding entries to .gitignore
  - Configuring symfony/web-profiler-bundle (>=6.1): From github.com/symfony/recipes:main
    Enabling the package as a Symfony bundle
    Copying files from recipe
      Created "./config/packages/web_profiler.yaml"
      Created "./config/routes/web_profiler.yaml"

                                                            
 Files have been reset to the latest version of the recipe. 
                                                            

  * Use git diff to inspect the changes.

    Not all of the changes will be relevant to your app: you now
    need to selectively add or revert them using e.g. a combination
    of git add -p and git checkout -p

  * Use git checkout . to revert the changes.

    New (untracked) files can be inspected using git clean --dry-run
    Add the new files you want to keep using git add
    then delete the rest using git clean --force

Könntet ihr mal die composer.json posten?

{
    "name": "shopware/production",
    "type": "project",
    "license": "MIT",
    "config": {
        "optimize-autoloader": true,
        "sort-packages": true,
        "allow-plugins": {
            "composer/package-versions-deprecated": true,
            "symfony/flex": true,
            "symfony/runtime": true
        }
    },
    "prefer-stable": true,
    "scripts": {
        "auto-scripts": {
            "assets:install": "symfony-cmd"
        },
        "post-install-cmd": [
            "@auto-scripts"
        ],
        "post-update-cmd": [
            "@auto-scripts"
        ]
    },
    "autoload": {
        "psr-4": {
            "Shopware\\Production\\": "src/"
        }
    },
    "repositories": [
        {
            "type": "path",
            "url": "custom/plugins/*/packages/*",
            "options": {
                "symlink": true
            }
        },
        {
            "type": "path",
            "url": "custom/static-plugins/*",
            "options": {
                "symlink": true
            }
        },
        {
            "type": "path",
            "url": "custom/plugins/*",
            "options": {
                "symlink": true
            }
        }
    ],
    "require": {
        "php": "^7.4.3 || ^8.0",
        "composer-runtime-api": "^2.0",
        "payone-gmbh/shopware-6": "5.0.2",
        "shopware/administration": "6.5.8.7",
        "shopware/core": "6.5.8.7",
        "shopware/elasticsearch": "6.5.8.7",
        "shopware/storefront": "6.5.8.7",
        "swag/amazon-pay": "9.0.0",
        "symfony/flex": "^2"
    },
    "require-dev": {
        "shopware/dev-tools": "*"
    },
    "extra": {
        "symfony": {
            "allow-contrib": true,
            "endpoint": [
                "https://raw.githubusercontent.com/shopware/recipes/flex/main/index.json",
                "flex://defaults"
            ]
        }
    }
}

Hat sich bei mir erledigt. Ich musste noch Amazon Pay aktualisieren, obwohl es deaktiviert war.

2 Likes