Update auf 5.6.3 - Links defekt

Nach dem Update auf 5.6.3 sind mehre Links defekt. Zum einen ganz oben rechts der “?Service/Hilfe”-Link. Zum anderen alle Links unten im Footer, also “Shop Service” und “Information”. Da wären bei mir eigentlich die Links zu AGD, Impressum, etc.

Wie kann ich das wieder herstellen?

Updateanleitung lesen könnte helfen, hat schon einen Grund, dass es diese gibt - wirklich!
https://docs.shopware.com/de/shopware-5-de/update-guides/update-guide-shopware-56?category=shopware-5-de/update-guides#shopseiten-gruppen-template-keys
Das Thema hat nun wirklich einen Bart…

1 Like

@sonic schrieb:

Updateanleitung lesen könnte helfen, hat schon einen Grund, dass es diese gibt - wirklich!
https://docs.shopware.com/de/shopware-5-de/update-guides/update-guide-shopware-56?category=shopware-5-de/update-guides#shopseiten-gruppen-template-keys
Das Thema hat nun wirklich einen Bart…

Achso ok, sry ich hatte nur den changelog gelesen. Dann lese ich mir das mal durch.  Allerdings bin ich der Meinung, dass ich vorher bei 5.6.2 war und dort das Problem nicht hatte. Wenn das aber, wie in deinem Link beschrieben, ein Problem seit dem Update auf 5.6 ist, dann hätte ich das Problem doch eigentlich schon früher beim Update auf 5.6 haben müssen.

@sonic schrieb:

Updateanleitung lesen könnte helfen, hat schon einen Grund, dass es diese gibt - wirklich!
https://docs.shopware.com/de/shopware-5-de/update-guides/update-guide-shopware-56?category=shopware-5-de/update-guides#shopseiten-gruppen-template-keys
Das Thema hat nun wirklich einen Bart…

In der Updateanleitung steht “Vor dem Update müssen ggf. verwaiste Einträge in s_order_details entfernt werden.” Da ich das ja versäumt habe, frage ich mich, ob ich das im Nachhinein trotzdem noch machen muss.

Außerdem steht in der Anleitung, dass die alten Shopseiten-Template-Keys geändert werden müssen. Wo finde finde ich die denn?

Jo, hätte schon bei 5.6.0 passieren müssen. Dann *Schulter zuck*
Das mit „_s_order_details“ _Hättest Du da ein Problem gehabt, wäre das Update selber mit einer Fehlermeldung ausgestiegen, hat es ja aber offensichtlich nicht gemacht.
Zu den „Links“ musst Du dann mal das Forum durchsuchen.

@Nemon schrieb:

@sonic schrieb:

Updateanleitung lesen könnte helfen, hat schon einen Grund, dass es diese gibt - wirklich!
https://docs.shopware.com/de/shopware-5-de/update-guides/update-guide-shopware-56?category=shopware-5-de/update-guides#shopseiten-gruppen-template-keys
Das Thema hat nun wirklich einen Bart…

In der Updateanleitung steht „Vor dem Update müssen ggf. verwaiste Einträge in s_order_details entfernt werden.“ Da ich das ja versäumt habe, frage ich mich, ob ich das im Nachhinein trotzdem noch machen muss.

Außerdem steht in der Anleitung, dass die alten Shopseiten-Template-Keys geändert werden müssen. Wo finde finde ich die denn?

Das kannst du einfach im Backend unter Einstellungen -> Grundeinstellungen -> Shopeinstellungen -> Shopseiten-Gruppen erledigen.