Unterstützung PHP < 7.0

Hallo @shopware‍,

evt. verstehe ich es nicht richtig, dann bitte ich meine Kritik zu ignorieren und mir ggf. ein paar Tipps zu geben :wink:

Die aktuelle Shopware Version 5.3 und auch das nächste Release 5.4 benötigen als minimal PHP Version 5.6. Das steht irgend wo in den Shopware Requirements und ist auch in der composer.json so hinterlegt, siehe shopware/composer.json at 5.4 · shopware/shopware · GitHub

Das heißt allerdings auch im Umkehrschluss, dass Composer keine Vendor Packages installiert, die als Minimal Version PHP 7.0 benötigen (ist natürlich logisch, hatte ich mir nur noch nie so vergegenwärtigt). Daher werde ich als Entwickler z. B. auch erst einmal weiterhin mit PHP Unit 5.6.* leben müssen, obwohl in der composer.json angegeben ist, dass PHPUnit auch bis 6.3 möglich wäre, siehe shopware/composer.json at 5.4 · shopware/shopware · GitHub

Wenn ich es also so weit richtig verstanden habe, dann würde ich es als Entwickler sehr begrüßen, wenn Shopware 5.4 als minimal PHP Version 7.0 vorrausetzen würde.

Viele Grüße

Marco 

 

Eigentlich sollte die Mindestanforderung so gar 7.1 sein, da sowohl für PHP 5.6 als auch für PHP 7.0 selbst der Security Support im Dezember abläuft. Active Support ist bei den beiden Versionen bereits letztes Jahr ausgelaufen. Siehe http://php.net/supported-versions.php

 

Hallo,

prinzipiell ja, es wird mindestens 5.6 benötigt. Dass es aber wirklich nötig ist, wird zur Laufzeit in der shopware.php überprüft. Composer legt ja nur seine eigenen Requirements fest.

Leider richtet sich es nicht danach, welche PHP Version wie lange supported wird, sondern es geht vielmehr darum, was der IonCube unterstützt. Fehlt dort die Unterstützung für eine PHP Version, dann fehlt sie auch in Shopware. Viele Plugins basieren noch auf dieser Verschlüsselungs-Erweiterung.

 

MFG

 

derwunner

IonCube gibt es aber m. E. bereits für 7.0

Bei Composer geht es aber halt auch darum, dass hier keine Vendor Package bzw. Versionen eingebunden werden, die PHP 7.0 vorausetzen. Insbesondere als Entwickler von Plugins bin ich dann dadurch eingeschränkt. Das kann dann “nur” auf das Schreiben von Tests zutreffen, da ich dann weiterhin PhpUnit 5 nutzen muss (7 ist gerade herausgekommen). Aber auch mein Plugin selbst schränkt es ein, wenn es auf Vendor Packages aufbauen soll, die PHP 7.0 vorausetzen. Hier muss ich entweder auf alte Versionen zurückgreifen (die ggf. nicht mehr supported werden und/oder bei denen es ggf. so gar Security Probleme gibt), weniger nützliche Alternativen einsetzen oder aber Code ggf. selbst schreiben. 

Laut Composer Doku könnte ich noch mit dem Parameter “–ignore-platform-reqs” arbeiten. Dann würde allerdings wohl “meine” Shopware Installation von der offizielen Version abweichen und ich kann mir nicht sicher sein, ob Shopware dann noch richtig funktioniert. 

Es hat nicht jeder - zumindest von denen, die die CE einsetzen - so den Einfluss auf den Hoster, was dieser bereitstellt.
Wenn 5.6 und 7.0 noch bis Ende Dezember Support haben, sollte man den Shopbetreibern nicht mit unnötigen Mindestvoraussetzungen den Shop gefährden.
Andersrum sollte die Ioncube-Seuche keinen Einfluss darauf haben, ob man die Mindestvoraussetzung auf 7.1 anheben kann, oder nicht. Interessiert bei SW doch eh keinen, ob ein Update mal wieder Plugins abschiesst - sind es dann halt mal verschlüsselte.
Unabhängig davon gibt es die Verschlüsselungsseuche inzwischen auch für PHP 7.1

1 Like

Ich kann als Shopbetreiber eines bestehenden Shops doch auch weiterhin Shopware 5.3 einsetzen. Wahrscheinlich wird ein Update von SW 5.3 auf SW 5.4 bei den Shopbetreibern, die eh noch PHP 5.6 einsetzen, so wie so eher selten durchgeführt. 

Warum sollte das so sein?
Warum soll ich nicht updaten? Mit 5.4 lässt SW ja auch wieder viele im Regen stehen, wo doch Bugfixe für 5.3.8 zugewiesen wurden.
Nur weil mein Hostingpaket nicht immer die aktuellste Version hat, muss ich als Shopbetreiber doch nicht auf ner alten SW-Bug-Version sitzen bleiben?

P.S.: Mir persönlich ist es egal - da ich schon auf 7.1.x bin und für spätestens 2019 auf eine zeitgemässe Shop-Software wechseln möchte.

Anders herum wird ein Schuh draus. Warum muss mein Shop auf alten Programmcode setzen, nur weil ein paar Hosting Anbieter eine seit 19 Jan 2017 nicht mehr (Update) aktiv (/Update) supportete PHP Version einsetzen. 

Die Aussage ist doch falsch: Supportende (Security) PHP 5.6 : 31 Dec 2018, PHP 7.0 : 3 Dec 2018

@sonic schrieb:

P.S.: Mir persönlich ist es egal - da ich schon auf 7.1.x bin und für spätestens 2019 auf eine zeitgemässe Shop-Software wechseln möchte.

Welche Shop-Software wäre das? Gerne auch per PN

Ok, das war etwas gemogelt, richtig hätte es natürlich aktiv  supportete PHP Version heißen müssen bei mir. 

1 Like

Ich gehe mal davon aus dass gerade sehr große Shops ältere Versionen im Einsatz haben. Wer hat denn die Zeit alle paar Tage ein Update durchzuführen? Vermutlich eher kleine Shops wo noch nicht viel los ist. Braucht man 7.1 unbedingt? Aus meiner Sicht nicht wiklich. Manche sollten lieber mal den Verkauf ankurbeln, als sich ständig um Updates neue Entwicklungen usw. Gedanken zu machen. Wink

1 Like

Ist das jetzt ein Pro PHP 7.0 in SW 5.4 oder eher ein Kontra?

@Vitago GmbH schrieb:

Braucht man 7.1 unbedingt? Aus meiner Sicht nicht wiklich. Manche sollten lieber mal den Verkauf ankurbeln, als sich ständig um Updates neue Entwicklungen usw. Gedanken zu machen. Wink

Es sollte allerdings mindestens PHP 7.0 statt PHP 5.6 eingesetzt werden, da der Shop dadurch mind. 15% schneller läuft und daher wahrscheinlich die Abbrecher Quote sinkt und ich dadurch mehr verkaufe :wink:

 

@Vitago GmbH schrieb:

Braucht man 7.1 unbedingt? Aus meiner Sicht nicht wiklich. Manche sollten lieber mal den Verkauf ankurbeln, als sich ständig um Updates neue Entwicklungen usw. Gedanken zu machen. Wink

Es sollte allerdings mindestens PHP 7.0 statt PHP 5.6 eingesetzt werden, da der Shop dadurch mind. 15% schneller läuft und daher wahrscheinlich die Abbrecher Quote sinkt und ich dadurch mehr verkaufe ;)

Ja und Nein! Unser Shop lief auch mit 5.6 sehr schnell, es hängt ja nicht nur davon ab welche php Version du einsetzt sondern auch welchen Server. Leider erwarten sich viele mit einem Billig-Hosting dass php7 Wunder wirkt und sind dann bitter entäuscht wenn dem nicht so ist. 

@Vitago GmbH schrieb:

es hängt ja nicht nur davon ab welche php Version du einsetzt sondern auch welchen Server. 

Auf dem selben Server eingesetzt habe ich aber höchstwahrscheinlich schon 15% mehr Geschwindigkeit, wenn ich PHP 7.0 statt PHP 5.6 einsetze.

Wenn es GEHT, sollte man schon auf PHP 7.x gehen - wenn es geht!
Selbst SW hatte immer wieder - obwohl 7.x freigegeben war - lange noch Stellen, die „nachgebessert“ werden mussten. Und dann kommen die unzähligen PlugIns ins Spiel, weil SW eben unter der Haube recht wenig kann, und davon vieles auch nicht wirklich richtig. Leider legt SW aber keinen Wert darauf, dass im Store angebotene PlugIns die zugesicherten Updates bekommen, und man alleine darum schon ggf. nicht auf PHP 7 wechseln kann, weil eben EIN wichtiges PlugIn dann doch ein Problem macht.
Für SW macht es auch kaum einen Unterschied, ob für PHP 5 unnützer Ballast mitgeschleppt wird, weil noch immer unnützer Ballast in Form von Wrappern aus ZEND-Zeiten vorhanden ist. Ich denke mal, bis Dezember sollte man nicht - für Entwickler - die breite Menge der unbedarften Shopbetreiber auf PHP 7.1 zwingen - guckt Euch doch im Forum um, wieviele technisch „Unwissende“ selber einen Shop „betreiben“.

Also, es gibt wie bereits erwähnt - schon länger ionCube für PHP 7.1. Das Problem ist bisher, dass die verschlüsselten Shopware Plugins nur bis 7.0 kompatibel sind. Am ionCube selber scheitert es nicht, sondern an den verschlüsselten Datein, die mit einer älteren Version verschlüsselt wurden. Daran arbeitet Shopware gerade soviel ich weiß. Steht aber auch hier so im Forum, also erstmal die Forums-Suche benutzen, bevor man Falschaussagen verbreitet.

Natürlich muss es nicht immer die neuste PHP Version sein. Da Shopware auch ältere Versionen parallel bedient, wird das Upgrade von Code Seiten her eh nicht viel bringen, bis auf die Interpreter Optimierungen.

Und ja, zeitgemäß wäre ein headless Shop. Das wird aber wohl bei Shopware nie passieren. Allein schon die ganzen Frontendler würden laut schreien, wo denn ihr jQuery geblieben ist…

@shopware‍ , schade, daß ihr Euch aus der Diskussion komplett raushaltet… Eine Antwort wie “SW 5.4 wird weiterhin als Mindestanforderung PHP 5.6 beinhalten” oder “wir prüfen das aktuell” wäre ja eigentlich mal ganz nett.

@hhmarco73 schrieb:

@shopware‍ , schade, daß ihr Euch aus der Diskussion komplett raushaltet… Eine Antwort wie “SW 5.4 wird weiterhin als Mindestanforderung PHP 5.6 beinhalten” oder “wir prüfen das aktuell” wäre ja eigentlich mal ganz nett.

Aus Shopware 5 upgrade guide

The minimum PHP version still is  PHP 5.6.4 or higher , though  PHP 7.x is highly encouraged.  

Ist also weiterhin >= 5.6.4

Viele Grüße