Umstellen auf PHP 7 mit 5.2.3

Guten Morgen,

ich habe gerade mal geschaut, ob ich meinen Shop nicht auf PHP 7 umstellen kann. Eigentlich habe ich “nur” PlugIns von Shopware aktiv.

Schalte ich aber auf PHP 7 erhatle ich folgende Meldung:

Site error: the ionCube PHP Loader needs to be installed. This is a widely used PHP extension for running ionCube protected PHP code, website security and malware blocking. Please visit get-loader.ioncube.com for install assistance. 

Ich dachte gelesen zu haben, dass die Version 5.2.x ohne ionCube auskommt.

Muss ich den noch irgendwie deaktivieren oder woran liegt das?

Danke.

 

Hallo,

vielleicht hilft dir das weiter:
http://community.shopware.com/Update-auf-php7_detail_1927.html?_ga=1.58669546.195450626.1464083288

Grüße,
Sven

Vermutlich hast Du doch irgendein Plugin, das den ionCube Loader benötigt.

Timme Hosting - schnelles nginx-Hosting

www.timmehosting.de

Hmm, müssen die PlugIns komplett gelöscht sein? Reicht es nicht diese zu deaktivieren?

 

Ich habe das gleiche Problem, zuvor hat er nur aber dafür konkret wegen dem SwagGlossar gemeckert!
Das habe ich dann deaktiviert und bekomme eben diese meldung im Backend, frontend läuft weiter…

Wo finde ich denn die vermutlichen IONCUBE - Plugin’s ?

An dieser Stelle sei nochmal gesagt IONCUBE NERVT! - Neulich an der Tankstelle:
Ihr diesel dieselt nicht, weil sie bei der Blauen Tankstelle waren und die hat Diesel 1.5, der AUTO fährt aber nur mit Diesel 2.0.
Leider bietet auch die Gelbe Tankstelle nur Diesel 1.6r2 weshalb ich jetzt fahrrad fahre. (Meldung im Auto kein AKKU)

 

Der Store bietet dir keine Möglichkeit herauszufinden, ob ein Plugin verschlüsselt ist oder nicht. Hier solltest du dich an den Hersteller / Entwickler des jeweiligen Plugins wenden und einfach mal anfragen.

Viele Grüße

@Hotte schrieb:

Ich habe das gleiche Problem, zuvor hat er nur aber dafür konkret wegen dem SwagGlossar gemeckert!
Das habe ich dann deaktiviert und bekomme eben diese meldung im Backend, frontend läuft weiter…

Wo finde ich denn die vermutlichen IONCUBE - Plugin’s ?

An dieser Stelle sei nochmal gesagt IONCUBE NERVT! - Neulich an der Tankstelle:
Ihr diesel dieselt nicht, weil sie bei der Blauen Tankstelle waren und die hat Diesel 1.5, der AUTO fährt aber nur mit Diesel 2.0.
Leider bietet auch die Gelbe Tankstelle nur Diesel 1.6r2 weshalb ich jetzt fahrrad fahre. (Meldung im Auto kein AKKU)

 

Hallo @Hotte,

das Problem zu Beginn des Threads nach Wechsel auf php 7 ist ein simpler Versionskonflikt in der Serverkonfiguration und kein Problem in Shopware. Die Version des  “Server-Moduls” Ioncube muss zu der PHP-Version des Servers passen. Wenn man seinen Server nicht richtig konfiguriert, ist das ja nun wirklich nicht die Schuld von Shopware. Und das Problem ist in der Regel mit einer Zeile in der php.ini erledigt.  Der Vergleich ist doch so nicht richtig.

@Aquatuning GmbH schrieb:

Der Store bietet dir keine Möglichkeit herauszufinden, ob ein Plugin verschlüsselt ist oder nicht. Hier solltest du dich an den Hersteller / Entwickler des jeweiligen Plugins wenden und einfach mal anfragen.

Viele Grüße

Hallo Aquatuning,

hier liegst du leider falsch: im Shopware Store steht da, ob ein Plugin verschlüsselt oder unverschlüsselt ist (oberhalb des Kaufbereichs).

Unverschlüsselt: http://store.shopware.com/scha199356547193/ausblendung-aller-preise-im-onlineshop-oder-einblendung-preise-erst-nach-login-und-je-kundengruppe.html

Verschlüsselt: http://store.shopware.com/imnxx17543218785/freitextfilter-/-filtern-nach-attributen.html

Beste Grüße

Sebastian

 

@sschreier schrieb:

hier liegst du leider falsch: im Shopware Store steht da, ob ein Plugin verschlüsselt oder unverschlüsselt ist (oberhalb des Kaufbereichs).

Ooohhh… das ist mir neu. Vielen Dank für den Hinweis!

Viele Grüße 

Außerdem steht SwagGlossar schon seit fast einem dreiviertal Jahr kostenlos und quelloffen auf Github. Wenn man da noch eine verschlüsselte Version hat, gibts auf Github die unverschlüsselte: GitHub - shopwareLabs/SwagGlossar