Themes kompilieren funktioniert nicht

Hallo liebe Shopware Community

Ich habe gerade das Update auf 5.2.5 durchgeführt. Nachdem ich die Shop Chache leeren wollte, merkte ich, das dies nicht mehr richtig funktioniert. Die Version 5.2.0 funktionierte.

Diese Optionen stehen ja für das leeren der Chache zur Verfügung. Die Optionen mit einem + funktionieren, die anderen mit - funktionieren nicht. Festgestellt anhand der auftauchenden Nachricht oben rechts.

  • Shopware Konfiguration
    +Template-Cache
    - Themes kompilieren
    - Http-Proxy-Cache
  • Proxies und Meta-Daten
  • Cache Suchfunktion
  • Index SEO-Urls

Wenn ich das Theme kompilieren möchte, fangt diese zwar an, bricht aber bei der Leere HTTP Chache ab.
Habe mich schon etwas vorinformiert betreffend Plugins. Habe demensprechend alle 3rd Plugins deaktiviert aber das Problem besteht weiterhin.

Woran könnte das liegen?

Besten Dank für eure Hilfe.

Mal im Log geschaut ob es dazu Fehler gibt?

Habe die aktuellste Datei von Heute drin. Diese beinhaltet folgendes.

[2016-08-17 08:27:27] core.ERROR: Reverse proxy returned invalid status code {"response":"\n\n 400 Bad Request\r\n\n\n \n 400\nBad Request\r\n\nIt is not a valid request!\n\n","code":400} {"uid":"72749f9"}

die Datei verfügt über noch weitere Zeilen, diese sind aber zu lang für das Textfeld.

Ich hab hier das gleiche Problem, im Log gibts dann immer einen neuen Eintrag:

[2016-08-24 17:33:53] core.ERROR: Reverse proxy returned invalid status code {"uid":"e476950"}

 

 

Wie sind denn die Einstellungen des Frontend-Cache (http-cache) bezüglich Proxy-Prune und Alternative Proxy-Url ?

Bei uns hat es mitgeholfen den Proxy-Prune abzuschalten.

Eventuell muss der Server mal neu gestartet werden um dieses mysteriöse cache-Problem zu lösen - hierzu mal an den Provider wenden. Aber so ganz konnten wir das Problem auch nicht eingrenzen - beim Support trat das Problem auch nur einmal auf, dann nicht mehr…

1 Like

Wir erhalten in unserem core_production.log auch seit dem letzten Update folgenden Fehler:

 

core.ERROR: Reverse proxy returned invalid status code 

Konnte schon einer feststellen woher er kommt?

Bei uns auch 2 Testsysteme auf gleichem Server.

Das eine macht nach 5.2.5 diese Probleme.

Ohne HTTP Cache kann ich wenigstens wieder kompilieren.

Gleicher Fehler im LOG

core.ERROR: Reverse proxy returned invalid status code 

 

Habt ihr die Möglichkeit festzustellen welche Request den “Bad Request” Response auslöst? Dürfte der Ajax Request für das Löschen des Caches sein, aber vielleicht noch mal mit der access.log abgleichen um den exakten Aufruf ermitteln zu können.

Hi  wo finde ich denn die Access.log? Hab das ganze Verzeichniss durchsucht.

 

PS: habe einen eigenen Thread aufgemacht, weil ich erst dacht das Problem hängt mit etwas anderem zusammen.
Tatsächlich scheint es aber auch das Proxy-Prune Thema zu sein (wußte nur nicht was @kulli‍ damit meint.)
Nun bin ich schlauer: https://forum.shopware.com/discussion/40243/http-cache-themes-kompilieren-fehler-suche-letzte-index-aktualisierung-01-01-2010-00-00/p1

Bei Apache Webserver in /var/log/apache2. Details dazu kannst Du hier nachlesen: https://synonymous.rocks/error-logging-fehlersuche-mit-shopware/

1 Like