SW 5.2 - Plugin Konfiguration für select und combo Boxen

Hallo Zusammen,

hat von einer eine Idee, wie die config.xml korrekt zu pflegen ist, sofern man in seiner Konfiguration gerne select oder combo Boxen verwenden möchte? 
Alle anderen Felder sind von der Pflege her kein Problem. Komme nur nicht auf die Idee wie das select mit den Values zu pflegen ist. Vielleicht hat ja jemand eine Idee.

Danke euch.

Liebe Grüße

Kevin

    Slogan Config New
    Meine Beschreibung
    
        
            elementText
            Textelement
            
            Beschreibung Textelement
        
        
            elementPassword
            Passworttextfeld
            
            Beschreibung Passwortfeld
        
        
            elementTextarea
            Textarea Feld 
        
        
            elementBoolean
            Boolean Feld 
            true
            Beschreibung Booleanfeld
        
        
            colorElement
            Farbauswahl
            Beschreibung Farbauswahl
        
        
            elementDate
            Date Feld
        
        
            elementDatetime
            Datetime Feld
        
        
            elementTime
            Time Feld
        
        
            elementInterval
            Interval Feld
        
        
            elementHtml
            HTML Eingabefeld
            
        
        
            elementMedia
            Media Selection Feld
        
        
            elementNumber
            Number Feld

 

Hallo,

unter tests/Unit/Components/Plugin/examples/config.xml steht bzgl. des Types “select” folgendes Beispiel:

            my-second-field
            Meine Selektion
            My Selection
            1
            Meine Feld Beschreibung
            My Field description

 

Leider hat es bei mir nicht funktioniert.

 

Hi, vielen Dank für die Info. 

Das es nicht funktioniert kann ich leider nur bestätigen. Habe es die letzten Minuten auch nochmals probiert :frowning:

Vielleicht meldet sich ja noch jemand… :slight_smile:

Liebe Grüße

Kevin

Da hier noch ein etwas ähnlicher Thread geöffnet wurde und hier eine erste Lösungsmöglichkeit genannt wurde, möchte ich gerne darauf verweisen: 

https://forum.shopware.com/discussion/comment/167809/#Comment_167809

Wichtig ist, dass der Typ select momentan wohl noch nicht über die XML-Datei zu pflegen ist. Den Punkt über die install-Methode habe ich noch nicht testen können. Finde es auch etwas unschön extra hierfür ein Model generieren zu müssen… 

Wollte nur Bescheid geben.

Liebe Grüße

Kevin

Egal wie’s früher mal war, jetzt (5.2.2x) geht’s z.B. so:

    priceCustomerGroup
    Kundengruppe für Preise
    Customer group for prices
    EK
    
        
            EK
            Endkunden
            End users
        
        
            H
            Händler
            Reseller

Viel Erfolg!

Geert

Bzw. im Fall der Kundengruppe natürlich noch eleganter so:

    priceCustomerGroup
    Kundengruppe für Preise
    Customer group for prices
    EK
    Shopware.apps.Base.store.CustomerGroup

 

Moin moin,

habe dazu auch einmal eine Frage: Wie muss man vorgehen wenn man den Category store nutzen möchte? Wenn ich

Shopware.apps.Base.store.Category

verwende, bekomme ich lediglich Deutsch und Englisch zur Auswahl?!?

Daniel

Update: Fülle das select Feld jetzt im Anschluss mit der “setOptions” Funktion. So wirklich schick ist das jetzt auch nicht, irgendwie?!?

  

@DannyDan schrieb:

Moin moin,

habe dazu auch einmal eine Frage: Wie muss man vorgehen wenn man den Category store nutzen möchte? Wenn ich

Shopware.apps.Base.store.Category

verwende, bekomme ich lediglich Deutsch und Englisch zur Auswahl?!?

Daniel

Shopware.apps.Category.store.CategoryPath sollte den Zweck erfüllen

Hi hoernchen,

Danke für den Tipp, das ganze funktioniert damit allerdings nicht.

Daniel

@DannyDan schrieb:

Hi hoernchen,

Danke für den Tipp, das ganze funktioniert damit allerdings nicht.

Daniel

 

Ja, sehe es auch grade. Es funktioniert nur, wenn man vorher Artikel > Kategorien aufgerufen hat …

@DannyDan schrieb:

Hi hoernchen,

Danke für den Tipp, das ganze funktioniert damit allerdings nicht.

Daniel

Ich habe ein Ticket angelegt: Shopware Issuetracker