Interne Links mit number in SW 5.3.2

@Shopware Ist es so gewollt, dass Interne Links in SW 5.3.x auch die Artikelnummer „?number=“ angehängt bekommen, selbst wenn die Artikel keine Variantenartikel sind?

  1. Dropdown oben in der Suche => ?number=
  2. Mapping in EKW - Banner ?number=

Hab jetzt auf die Schnelle im Issue-Tracker nichts dazu gefunden - find ich aber unschön - in vielen Bereichen wird es nicht angehängt.

Ja, grundsätzlich schon. 

An vielen Stellen wurde Varianten Unterstützung eingebaut. Bei der Suche ist es zum Beispiel absolut notwendig. Da die gesuchte Variante zum Beispiel anhand der Artikelnummer, auch direkt aufgerufen wird. Bei den Einkaufswelten ist es genauso dort gibt es mittlerweile auch ein Varianten Support. Du kannst ja einzelne Varianten angeben.

Daher ist es an einigen Stellen natürlich auch so das ist bei regulären Artikeln auch mit dem number Parameter erscheinen kann.

Das sollte beziehungsweise ist auch grundsätzlich kein Problem. Oder hast du einen bestimmten Fall wo ist zu einem Problem führt? Daher gibt es ja bei der Artikel Detailseite speziell den canonical Tag

1 Like

Nein, ein Problem habe ich nicht damit, ich fand es nur ungewöhnlich. Wearing-Sunglasses Darum auch erst eine Frage hier, ehe ich ein Ticket aufgemacht hätte. Wenn es so sein soll, und es mich irgendwann mal stört, muss ich mal gucken, ob ich das wieder via Plugin entfernen kann, wenn der Artikel kein Variantenartikel ist.  Wink

Eins noch - aber 5.2.27 (5.3.2 hab ich nicht die Situation gegeben).
Einkaufswelt => Element Kategorie-Teaser => zufälliger Artikel: Element bleibt „leer“, wenn die Kategorie ein Productstream ist.

a) so gewollt (systembedingt)?
b) nicht gewollt => mit 5.3.x gefixt?

Korrekt. A = Systembedingt

Es gibt ja keine Artikel in der Kategorie. Die Kategorie ist hier ja nur „verlinkt“ mit einem Stream.

Richtige Zuweisung zu einer Kategorie, auf die sich das System in Funktionen beziehen kann, gibt es in dem Fall nicht.

Sebastian

1 Like

Hallo zusammen,

das Anfügen von „?number=Ordernumber“ führt bei uns dazu, dass das Laden von Artikeldetailseiten aus der LiveSuche (nicht von der Seite mit den Suchergebnissen) lange Ladezeiten wie bei Aufruf nicht gecashter Artikeldetailseiten haben.

@SebastianKlöpper‍  Gibt es eine Möglichkeit das zu umgehen?

 

Gruß
Jens

 

 

 

Hallo @JensBAG‍,

Hallo @SebastianKlöpper‍,

 

habt ihr zu dem Thema mit dem Caching eine Lösung gefunden oder gibt es in neueren Versionen eine Einstellung. Wir haben genau das identische Thema mit dem Caching. Aufrufe ohne number gehen flüssig. Die Links aus der Ajax-Search hingegen dauern.

Evtl. gibt es ja auch eine Lösung über die Templates etc.

Gruß

Peter