Infinite Scrolling funktioniert nicht!

Hallo,

das Infinite Srolling funktioniert bei mir nicht. http://test.futterlieferant.de.

Alle Einstellungen sind standard, Das Kreissymbol zum Nachladen wird angezeigt, aber dann passiert nichts mehr.

Caches sind geleert, Theme neu compiliert (Standard). Ich habe keine Idee.

Bitte um Hilfe.

Gruß

René Schlacht

Hallo René,

beim Request, der die Daten für das Infinite Scrolling nachlädt kommt es zu einem Fehler. Bitte schalte einmal das Error Reporting ein, um zu sehen, was genau für ein Fehler auftaucht. http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html#Frontend_Error_Reporter

Viele Grüße aus Schöppingen

cool Michael Telgmann

Inkompatibiles Plugin, wetten? :wink: :wink: :wink:

Hallo Michael,

beim Error reporting kommt kein Fehler. Mit Firebug bekomme ich folgende Fehlermeldung:

http://test.futterlieferant.de/widgets/Listing/ajaxListing?p=2&mode=next&c=238  Service unavailable 503

Vielen Dank für Deine Mühe.

Gruß

Rene

Hi René,

Entity of type ‘Shopware\Models\Category\Category’ for IDs id(0) was not found in vendor/doctrine/orm/lib/Doctrine/ORM/EntityNotFoundException.php on line 47

Stack trace:

#0 vendor/doctrine/orm/lib/Doctrine/ORM/Proxy/ProxyFactory.php(195): Doctrine\ORM\EntityNotFoundException::fromClassNameAndIdentifier(‘Shopware\Models…’, Array) #1 var/cache/production_201610171619/doctrine/proxies/__CG__ShopwareModelsCategoryCategory.php(747): Doctrine\ORM\Proxy\ProxyFactory->Doctrine\ORM\Proxy{closure}(Object(Shopware\Proxies__CG__\Shopware\Models\Category\Category), ‘getProductBoxLa…’, Array) #2 var/cache/production_201610171619/doctrine/proxies/__CG__ShopwareModelsCategoryCategory.php(747): Closure->__invoke(Object(Shopware\Proxies__CG__\Shopware\Models\Category\Category), ‘getProductBoxLa…’, Array) #3 engine/Shopware/Core/sCategories.php(552): Shopware\Proxies__CG__\Shopware\Models\Category\Category->getProductBoxLayout() #4 engine/Shopware/Controllers/Widgets/Listing.php(190): sCategories->getProductBoxLayout(‘238’) #5 engine/Library/Enlight/Controller/Action.php(159): Shopware_Controllers_Widgets_Listing->ajaxListingAction() #6 engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch(‘ajaxListingActi…’) #7 engine/Library/Enlight/Controller/Front.php(223): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp)) #8 engine/Shopware/Kernel.php(177): Enlight_Controller_Front->dispatch() #9 vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #10 engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #11 vendor/symfony/http-kernel/HttpCache/HttpCache.php(444): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true) #12 vendor/symfony/http-kernel/HttpCache/HttpCache.php(344): Symfony\Component\HttpKernel\HttpCache\HttpCache->fetch(Object(Symfony\Component\HttpFoundation\Request), true) #13 engine/Shopware/Components/HttpCache/AppCache.php(178): Symfony\Component\HttpKernel\HttpCache\HttpCache->lookup(Object(Symfony\Component\HttpFoundation\Request), true) #14 vendor/symfony/http-kernel/HttpCache/HttpCache.php(210): Shopware\Components\HttpCache\AppCache->lookup(Object(Symfony\Component\HttpFoundation\Request), true) #15 engine/Shopware/Components/HttpCache/AppCache.php(114): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #16 shopware.php(113): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request)) #17 {main}

Sieht mir doch nach einer schönen Fehlermeldung aus  Wink Aus irgendeinem Grund versucht er die Kategorie mit der ID 0 zu nutzen, obwohl der die 238 übergeben bekommt. Wie NextMike auch schon vermutet hat, wird da wohl ein Plugin rein spielen. Deaktivere mal Plugins, die irgendwie ins Listing oder auf die Detailseite Einfluss haben.

Viele Grüße aus Schöppingen

cool Michael Telgmann

@NextMike schrieb:

Inkompatibiles Plugin, wetten? ;) ;) ;)

Gerne. Noch kein PlugIn drin ;-). Original Template auch nicht geändert. Das abgeleitete mit neuem Logo macht den gleichen Fehler wie das Originale :frowning:

Gruß

René 

So, jetzt läufts. Ich hatte einmal alle Kategorien und Artikel gelöscht und dabei die root-Kategorien anscheinend nicht richtig angelgt.

Jetzt habe ich die Datenbank noch einmal geleert und jetzt gehts. Vielleicht wäre es Möglich die Anleitung zum Leeren des Shops auf die 5er Version zu aktualisieren.

 

Danke Euch!

Gruß

René Schlacht

Für Alle die immer noch nach eine Lösung suchen, Infinite Scrolling wird auch im Browser geblockt falls “Überall SSL verwenden” nicht aktiviviert ist. 

 

Gruß 

Amin Nayerhabibi

cool

1 Like

Hatte das Problem nun auch das beim Infinity Scrolling unter 5.4.1 unter gewissen umständen der Fehlercode 500 kam.

Schuld daran waren die Plugins „HTML-Text Tabs SEO Widget“ und „Advanced Cart“ auf vershciedenen Seiten. Ich muss aber auch dazu sagen, dass die beiden Plugins noch nciht für 5.4 freigegeben waren und es nur auftrat wenn die Ansicht/Produktlayout „Nur wichtige Informationen“ gewählt war.

Also werr auchd en Code 500 bekommt sollte erst mal den „Sicheritsmodeus“ unter Plugins aktivieren um zu schauen ob es an einem Plugin liegt.