https Fehler

Guten Abend, wenn ich versuche meinen Shop über https:// aufzurufen erhalte ich den auf dem Screenshot abgebildeten Fehler. Dieser Fehler tritt nur manchmal auf, aber ich finde die Ursache leider nicht. Ich habe nur das PayPal und DHL Plugin installiert. Am Theme wurde auch noch nichts verändert (Shopware Responsive) Vielen Dank vorab.

Dads Bild zeigt nichts an, Link zum Shop ?

Also bei dem Bild ist ja überhaupt keine URL eingetragen ? Dann kommt natürlich auch nix. Bzgl. des Links: Hier müsstest du am besten noch eine nginx Rule einfügen, dass der Shop immer auf https geleitet wird. Sodass dieser praktisch nicht ohne https aufrufbar ist. Denn die Startseite ist ohne https. server { listen 80; return 301 https://$host$request\_uri; }

1 Like

[quote=„kayyy“]Also bei dem Bild ist ja überhaupt keine URL eingetragen ? Dann kommt natürlich auch nix. Bzgl. des Links: Hier müsstest du am besten noch eine nginx Rule einfügen, dass der Shop immer auf https geleitet wird. Sodass dieser praktisch nicht ohne https aufrufbar ist. Denn die Startseite ist ohne https. server { listen 80; return 301 https://$host$request\_uri; }[/quote] Danke für deine Antwort kayyy. Ich habe den Link des Screenshots erneuert und nun müsste etwas zu sehen sein. Die Startseite wird seit dem Upgrade auf Shopware 5 nicht mehr automatisch auf die https:// weitergeleitet (Einstellungen im Backend wurden nicht auch verändert und in der Datenbank ist auch SECURE und ALWAYS_SECURE=1 richtig eingetragen) In der .htaccess Datei habe ich keinen Fehler gefunden. [code]
RewriteEngine on

#RewriteBase /shopware/

Https config for the backend

#RewriteCond %{HTTPS} !=on
#RewriteRule backend/(.*) https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteRule shopware.dll shopware.php
RewriteRule files/documents/.* engine [NC,L]
RewriteRule backend/media/(.*) media/$1 [NC,L]

RewriteCond %{REQUEST_URI} !(/(engine|files|templates|themes|web)/)
RewriteCond %{REQUEST_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ shopware.php [PT,L,QSA]

Fix missing authorization-header on fast_cgi installations

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

# Block access to VCS directories
RedirectMatch 404 /\.(svn|git|hg|bzr|cvs)(/|$)
# Staging environment #SetEnvIf Host „staging.test.shopware.in“ SHOPWARE_ENV=staging # Development environment #SetEnvIf Host „dev.shopware.in“ SHOPWARE_ENV=dev #SetEnv SHOPWARE_ENV dev DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration
# Deny all requests from Apache 2.4+.

Require all denied

# Deny all requests from Apache 2.0-2.2.
<ifmodule>
    Deny from all
</ifmodule>

# Enable gzip compression
AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/javascript application/json


ExpiresActive on
ExpiresDefault „access plus 1 month“

<ifmodule mod_headers.c>
    Header append Cache-Control "public"
    Header unset ETag
</ifmodule>

FileETag None

# Match generated files like: # 1429684458_t22_s1.css # 1429684458_t22_s1.js

Header set Cache-Control „max-age=31536000, public“

<ifmodule mod_expires.c>
    ExpiresActive on
    ExpiresDefault "access plus 1 year"
</ifmodule>

# Disables auto directory index
Options -Indexes

Options -MultiViews

php_value memory_limit 256M

php_value max_execution_time 120

php_value upload_max_filesize 20M

php_flag phar.readonly off
php_flag magic_quotes_gpc off
php_flag session.auto_start off
php_flag suhosin.session.cryptua off
php_flag zend.ze1_compatibility_mode off
# AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php [/code] Wo kann ich die nginx Rule einfügen? Steht diese schon nicht schon „übersetzt“ in der htaccess File?

Kontaktiere dazu am besten mal deinen Hoster, der sollte dir weiterhelfen können.