Cronjobaufruf unter 4.2 läuft nicht

Mir hat der Support einen guten Tipp gegeben, vielleicht hilft es ja auch bei Dir, du musst in der Medienverwaltung unter Bilder rechts auf das Zahnrad klicken, dann kannst du die Thumbnails neu erstellen lassen. Hat bei mir geholfen! D

2 Likes

Danke…wo ist das??? GEFUNDEN - Danke sehr

Ja hat geholfen vielen Dank! D.h. 1. PlentyConnector exportiert die Bilder korrekt 2. die Autom. Shopware thumbnail Erstellung nach PlentyExport schlägt fehl? ging ja vorher „automatisch“

[quote=„transpal“]Ja hat geholfen vielen Dank! D.h. 1. PlentyConnector exportiert die Bilder korrekt 2. die Autom. Shopware thumbnail Erstellung nach PlentyExport schlägt fehl? ging ja vorher „automatisch“[/quote] Hi, ne das ist nicht ganz richtig. Wir haben mit der Version 4.2 ein Feature eingebaut mit dem man über Batch Processing, die Thumbnails generieren lassen kann. Außerdem haben wir eine Funktion hinzugefügt, mit der man diese Generierung auch manuell starten kann. Ein Shopware Bug in diesem Bereich ist uns nicht bekannt. Vg, Marcel

Fakt ist aber, dass in Shopware die Thrumnails nicht angezeigt werden, wenn aus der PLentyumgebung Artikel zu Shopware exportiert werden. Erst wenn ich im nachhinein die Generierung in der Medienverwaltung anstoße werden die Thrumbnails angezeigt.

Problem ist aber das die Plenty Schnittstelle scheinbar recht häufig die Bilder aktualisiert, und damit sind die Bilder dann wieder nicht mehr sichtbar. Das ist ärgerlich da wir so natürlich nichts verkaufen, wenn keine Bilder angezeigt werden. Ich kann ja auch nicht alle paar Stunden in der Medienverwaltung das generieren der Bilder anschubsen. Ziemlich nervig das ganze… Gibt es hier bald eine vernünfige Lösung? Plenty reagiert nicht mehr auf Tickets die was mit Shopware zu tun haben, zumindest nicht mehr bei uns…

Da Plenty die Bilder übergibt, aber SW die Thrumbnails nicht generiert, sehe ich eher das Problem auf der SW Seite???

ehrlich gesagt? Mir egal! Wir zahlen bei beiden, soll einer das Problem lösen und fertig. Kann ja nicht so kompliziert sein… :sunglasses:

Hallo, also so wie Marcel von Shopware es beschreibt - müsste der PlentyConnector erweitert werden sodass er, dass neuen 4.2 Feature (Thumbnails generieren) nach Bildupdates anstösst. @Marcel S: wie wurde es denn vorher (< 4.2) gelöst wenn über die API Produktbilder hinzugefügt oder geändert wurden?

Hallo Zusammen, wir haben eine Info von Plenty bekommen. Der aktuelle Connector ist nicht kompatibel mit Shopware 4.2.x. Maximal bis 4.1.x. Leider war der Connector aufgrund eines Fehler auch unter 4.2.x installierbar. Dies ist nun nicht mehr möglich, alle Kunden die mit dem Connector arbeiten möchten benötigen ein Shopware System der Version 4.1. Gruß Patrick Schücker

Gibt es einen Zeitpunkt, den Plenty nennt für 4.2 Ready?

äääh, das kommt jetzt aber ein bisschen spät…

[quote=„musikus-hifi“]äääh, das kommt jetzt aber ein bisschen spät…[/quote] Mir stehen auch die Haare zu Berge! Ging es bei Dir unter 4.14 mit PlentyConnector 1.54 ?

glaub schon, naja was heißt gehen, so richtig arbeitet die Schnittstelle eigentlich selten. Irgendwas ist immer. In der Vorgängerversion wurden die Bestellungen ohne Kundendaten in Plenty eingelesen, zumindest ohne Rechnungsanschrift, dies ließ sich auch in Plenty nicht korrigieren, es kamen also Rechnungen ohne Anschrift raus, ohne eine Chance eine Rechnungsadresse zu hinterlegen. Angeblich weil die Anrede fehlte. Da der Kunde aber nur im Shop bestellen kann, wenn eine Anrede ausgefüllt ist (ist ja eigentlich bei Option Button unmöglich keinen zu wählen)frage ich mich wie es dazu kam. Ich gehe davon aus, das die Adressdaten des Kunden überschrieben werden, wenn er per PayPal oder amazon Payments zahlt. Dies führt dann dazu, das wohl das Feld Anrede leer ist und in Plenty dann nur Murks ankommt. Wie das Problem gelöst wird hat man mir leider nicht mitgeteilt. Wäre auch nicht deren Problem, das muss Shopware lösen. Eigentlich eine tolle Idee mit Shopware und Plenty, aber es hapert doch stark an der Ausführung.

Hallo, also der aktuell im Store verfügbare ist bis 4.1.4 freigegeben. Gruß Patrick Schücker

Hallo, wir haben nun auf 4.1.4 Downgegraded - nun lässt sich der PlentyConnector nicht mehr auf 1.5.4 updaten bzw. neu installieren - wenn ich die Datei (Version) PLENTY00735 manuell runterlade steht in der Bootstrap.php immer noch ‘1.4.21’: public function getVersion() { return '1.4.21'; } bekommen ich nicht die aktuelleste Version oder ist die Info im Quellcode falsch?

Habe die gleiche Prozedur gerade hinter mir. Von 4.2 auf 4.1.4 Bei uns lässt sich das Plentyplugin installieren. 1.5.4