"Compiler Cashing deaktivieren" funktioniert nicht

Guten Tag an alle,

leider wurde ich in der Suchfunktion unter „Compiler“ nicht fündig, daher ein neuer Thread.
Ich lerne momentan Shopware anhand der Videos in der Academy kennen, bin ergo noch recht unerfahren, was das Programm sowie Less, Compiling etc. anbelangt.

Ich bin in den Videos jeden Konfigurationsschritt durchgegangen, habe sowohl NetBeans als auch PHP Storm ausprobiert und hatte immer das selbe Ergebnis:
Sobald ich im all.less eine Änderung durchführe, wird im Frontend keine Veränderung angezeigt. Erst sobald ich das Compiling manuell über den Theme Manager anstoße, passiert etwas.

Das Häkchen bei „Disable compiler cashing“ unter den Theme Manager Einstellungen ist gesetzt.
Ebenso ist unter Cache/Performance -> Settings -> HTTP Cache das Häkchen unter „Activate HTTP cache“ wie im Video erwähnt NICHT gesetzt.

Das Einzige, was mir soweit aufgefallen ist:
Sowohl mit NetBeans als auch PHP Storm wurde mir beim allerersten Speicherversuch der all.less-Datei angezeigt, ob ich denn das automatische Compiling aktivieren will. Danach sollte ich das in den Einstellungen aktivieren.
Bei NetBeans wurde kein Compiler (?) gefunden, somit konnte ich nicht bestätigen. Bei PHP Storm hingegen konnte ich bestätigen, mir wurde Sekunden später allerdings ein Error ausgegeben.

Kann es etwas damit zu tun haben und wenn ja, was kann ich dagegen tun?

Vielen Dank schon Mal!

Cache geleert nach der Änderung?

Schreibrechte im Verzeichnis /web vorhanden?

Generell funktioniert das. Es wird dann halt pro Aufruf das CSS und JS erzeugt. Ist dazu natürlich merkbar langsam.
In PHPStorm usw. musst du dafür nichts einstellen.

1 Like

Ich hab eben im Chrome den Cache manuell geleert, hat funktioniert!

Allerdings dachte ich, dass das Setzen des Häkchens bei “Disable compiler cashing” bewirken soll, DASS das automatisch passiert?
Bzw. statt dass ich den Cashe leeren muss eben dass es gar nicht erst gecasht wird (disable cashing).

Ansonsten nimmt es sich ja vom Aufwand nicht allzu viel, ob ich nun den Cashe jedesmal manuell lösche und die Seite aktualisiere (was offensichtlich eben länger dauert), oder aber ob ich jedesmal das Theme neu lade.

Gibt es da keine Möglichkeit, dass man nicht jedesmal nach einer Änderung den Cashe im Browser nochmal leeren muss?

In der Browserkonsole kannst du disable Cache aktivieren. 

1 Like

Vielen Dank, hat geklappt! :slight_smile: