[admin:watch] Login geht nicht unter Version 6.2.0 (RC1)

Tach zusammen,

ich kann mich unter Version 6.2.0 (RC1) normal anmelden und die Logindaten stimmen auch (admin:shopware).
Befinde ich mich allerding im watch Modus (./psh.phar administration:watch), dann kann ich mich nicht anmelden.
Hab’s mit mehreren Browsern (+ Inkognito) getestet.

Habt ihr auch das Problem?

// edit
Hab über bin/console mal nen neuen User angelegt.
Unter diesen Benutzer kann ich mich auch nicht unter admin:watch anmelden.

gleiches Problem bei mir. Nach dem Update ist kein Login mehr möglich.

1 Like

Hallo,

verwendet ihr eine abweichende URL zum Öffnen der Administration? Wenn ja, bitte öffnet dann die Administration über localhost:
Wenn es vorher beispielsweise über http://docker.vm:8080 gemacht wurde, bitte http://localhost:8080 verwenden. So solltet ihr euch bei Verwendung von administration:watch wie gewohnt einloggen können.

Liebe Grüße,

Ramona

Guten Morgen,

seit 6.1.0 (RC1) öffne ich den watcher so und hab auf eine lokale Netzwerk-IP verwiesen:

192.168.123.45:8080

Wie gesagt seit 6.2.0 (RC1) geht das nicht mehr.

localhost ist bei mir auch nicht möglich da ich die dev Instanz auf einem eigenen Server betreibe

Hey guys,

can you try to change the following code in the core:
 

// platform/src/Administration/Resources/app/administration/src/core/service/login.service.js

...

function cookieStorageFactory() {
    const domain = window.location.hostname; // change this line
    const path = context.basePath + context.pathInfo;

    // Set default cookie values
    return new CookieStorage(
        {
            path: path,
            domain: domain,
            secure: false, // only allow HTTPs
            sameSite: 'Strict' // Should be Strict
        }
    );
}

...

If this works for you then I would try to create a ticket for this to fix this problem in the next version.

1 Like

thank you, it works.
i can login right now.
BUT

now i get JavaScript errors after i logged in.

 

I forgot the Web Worker which don´t have access to the window. Can you try this:

 

// platform/src/Administration/Resources/app/administration/src/core/service/login.service.js

...

function cookieStorageFactory() {
    let domain;

    if (typeof window === 'object') {
        domain = window.location.hostname;
    } else {
        // eslint-disable-next-line no-restricted-globals
        const url = new URL(self.location.origin);
        domain = url.hostname;
    }

    const path = context.basePath + context.pathInfo;

    // Set default cookie values
    return new CookieStorage(
        {
            path: path,
            domain: domain,
            secure: false, // only allow HTTPs
            sameSite: 'Strict' // Should be Strict
        }
    );
}

...

 

4 Likes

great, thank you.

work, thx

Merkwürdig, bei mir funktioniert das trotz der Änderung nicht. Gleiches verhalten wenn ich versuche mich einzuloggen.

Änderung wie oben beschrieben vorgenommen, Admin neu gebaut, cache geleert, browsercache geleert.
Habe ich evtl. noch etwas vergessen?

Danny

Hat keiner eine Idee wie man das Problem mit einer Vagrant Umgebung in den Griff bekommen kann?
Manuell jedesmal den Adminkram zu bauen dauert nicht nur immer knapp eine Minute, sondern ist auch super umständlich. :frowning:

Danny

The solution that worked for @DannyDan‍ I was still unable to log in. After some hours wasted, I found this:

# First, change the "login.service.js" file as proposed by
# jleifeld above.

cd /home/vagrant/shopware-dev/platform/src/Administration/Resources/app/administration

export PROJECT_ROOT="/home/vagrant/shopware-dev"
export ENV_FILE="$PROJECT_ROOT/.env"
export PORT="8080"
export HOST="192.168.33.10"
export APP_URL="http://192.168.33.10"

# Not necessary, personal recommendation:
export ESLINT_DISABLE=true

npm run dev
# ... wait until ready... then log in at
# "http://192.168.33.10:8080/"

Relevant data missing in a context … this seems to be a bit of a theme in development with Shopware 6 at the moment (not just in JS, unfortunately).

Since I am already writing this post: big compliment to the Shopware guys for the smooth installation of the vagrant environment Shopware Thumb-Up! This is so nice, please don’t let it die!

1 Like

No luck with any of the approaches.

Is there a way to run administration:build (which works just fine) in a way that int produces  „dev files“?

I don’t care about hot reloading, all I need is the Vue chrome plugin  working.

This is still in problem in Vagrant 6.3.0.1 Please fix that.

@euroxid Be aware to copy the code directly ito the vendor folder here: (SW 6.3.0.1)

/shopware-platform-vagrant/shopware-dev/vendor/shopware/platform/src/Administration/Resources/app/administration/src/core/service/login.service.js

not here:

/shopware-platform-vagrant/shopware-dev/platform/src/Administration/Resources/app/administration/src/core/service/login.service.js

 

@euroxid schrieb:

No luck with any of the approaches.

Is there a way to run administration:build (which works just fine) in a way that int produces  “dev files”?

I don’t care about hot reloading, all I need is the Vue chrome plugin  working.

1 Like

Moin Zusammen,

der Source-Code-Hack funktioniert auch in der 6.3.0.2 noch, vielen Dank dafür! Im Vergleich zur 6.1.x fehlt bei mir aber das automatische Reload:

  • Da der reine Aufruf von localhost:8080 zum Aufruf des HMR-Admin bei mir, auch mit der shopware.ova (Shopware 6 - Setting Up a Local Environment with Virtual Box) und NAT nie funktioniert hat, sind die Server in den VMs mit einer festen IP verbunden und werden für das HMR z.B. per :9000 aufgerufen
  • Das wiederum wird innerhalb der VM von Apache nach localhost:8080 geproxied. Damit läßt sich schon mal das Backend aufrufen
  • Der Core-Hack hilft dann beim Einloggen
  • Zusätzlich hat die 6.3.x ein fehlerhaftes Script für ./psh.phar administration:watch (Shopware Issuetracker). Die dort beschrieben Lösung funktioniert. Für das Production-Template habe ich die analoge Änderung an der Datei shopware-root/bin/watch-administration.sh durchgeführt (bin/console feature:dump auskommentiert).
  • Damit werden bei mir alle Skripte kompiliert und stehen dem dev-server zur Verfügung. Allerdings hagelt es GET http://localhost:8080/sockjs-node/info?t=1599396756356 net::ERR_CONNECTION_REFUSED Fehler, was auch kein Wunder ist, da localhost:8080 für den Browser ja in Leere führt.

Daher lädt der Browser eben nicht neu - ist nicht sooo dramatisch, aber wenn jemandem noch was dazu einfällt (@rschwering‍, [@Moritz Naczenski](http://forum.shopware.com/profile/14574/Moritz Naczenski “Moritz Naczenski”)‍ ), gerne immer her damit! :wink:

Beste Grüße,
devnullroot