5.2.2 Kunden können sich nicht mehr anmelden

Seit dem wir die Version 5.2.2 nutzen können sich unsere Kunden nicht mehr anmelden.
Es erscheint „Ups es ist ein Fehler aufgetreten“.

Im Forum habe ich einen Hinweis gefunden bezüglich CSRF Protection.
Also habe ich folgenden Code in die config.php geschrieben und es ging erstmal.

 'csrfProtection' => [
    'frontend' => false,
    'backend' => false

Jetzt bleibt noch die Frage wo der Fehler liegt.
Folgende Plugins sind bei uns aktiv:

Keiner ähnliche Probleme?

@kessyfashion schrieb:

Keiner ähnliche Probleme?

Hallo,

am besten ergänzt du die config.php noch um die entsprechenden Debug - Parameter, um die “richtige” Fehlermeldung zu erhalten: http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html?#Frontend_Error_Reporter .

Beste Grüße

Sebastian

Danke @Sebastian

The provided X-CSRF-Token is invalid. Please go back, reload the page and try again. in engine/Shopware/Components/CSRFTokenValidator.php on line 151

Stack trace:

#0 [internal function]: Shopware\Components\CSRFTokenValidator->checkFrontendTokenValidation(Object(Enlight_Controller_ActionEventArgs))
#1 engine/Library/Enlight/Event/Handler/Default.php(91): call_user_func(Array, Object(Enlight_Controller_ActionEventArgs))
#2 engine/Library/Enlight/Event/EventManager.php(214): Enlight_Event_Handler_Default->execute(Object(Enlight_Controller_ActionEventArgs))
#3 engine/Library/Enlight/Controller/Action.php(143): Enlight_Event_EventManager->notify('Enlight_Control...', Object(Enlight_Controller_ActionEventArgs))
#4 engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('loginAction')
#5 engine/Library/Enlight/Controller/Front.php(226): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))
#6 engine/Shopware/Kernel.php(176): Enlight_Controller_Front->dispatch()
#7 vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#8 engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)
#9 vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\Request), true)
#10 vendor/symfony/http-kernel/HttpCache/HttpCache.php(275): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Request), true)
#11 engine/Shopware/Components/HttpCache/AppCache.php(133): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#12 vendor/symfony/http-kernel/HttpCache/HttpCache.php(206): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundation\Request), true)
#13 engine/Shopware/Components/HttpCache/AppCache.php(114): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)
#14 shopware.php(101): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Request))
#15 {main}

 

Hab jetzt die Plugins die nicht 5.2.2 fähig sind von deaktiviert auf deinstalliert.
Das scheint es gewesen zu sein. :-/

Von welcher Version bist Du umgestiegen? CSRF generell zu deaktivieren empfehle ich nicht.
Hier auch ein paar Tipps: https://synonymous.rocks/shopware-5-2-csrf-token-is-invalid/

5.0.1 wars glaub.

Es läuft ja jetzt. :slight_smile:

Ja, aber CSRF ist ein wichtiges Security-Feature. Daher: Nicht deaktivieren… :slight_smile: