edobaedoba MemberComments: 19 Received thanks: 0 Member since: March 2011 edited April 2015
Hallo zusammen,

ich habe gerade auf einem Testserver mal meinen aktuellen Shop, Version 4.3.6 auf 5 RC3 umgestellt. Funktioniert soweit alles erst mal gut. Nur die Artikel lassen sich nicht mehr aufrufen. Das logfile sagt mir:
[2015-04-26 02:03:30] core.ERROR: exception 'Doctrine\ORM\ORMException' with message 'The identifier id is missing for a query of Shopware\Models\Category\Category' in /is/htdocs/wp11100701_V28X3ZWAA9/staging/vendor/doctrine/orm/lib/Doctrine/ORM/ORMException.php:259 Stack trace: #0 /is/htdocs/wp11100701_V28X3ZWAA9/staging/vendor/doctrine/orm/lib/Doctrine/ORM/EntityManager.php(427): Doctrine\ORM\ORMException::missingIdentifierField('Shopware\\Models...', 'id') #1 /is/htdocs/wp11100701_V28X3ZWAA9/staging/vendor/doctrine/orm/lib/Doctrine/ORM/EntityRepository.php(154): Doctrine\ORM\EntityManager->find('Shopware\\Models...', NULL, 0, NULL) #2 /is/htdocs/wp11100701_V28X3ZWAA9/staging/engine/Shopware/Core/sCategories...
Hat jemand vielleicht eine Idee, wie ich dies Problem lösen kann?
Danke im Voraus und viele Grüße
Lorenz

Comments

  • German-Fashion-BrandGerman-Fashion-Brand MemberComments: 1 Received thanks: 0 Member since: April 2015
    Hallo,

    der Post steht auf "gelöst".

    Gibt es eine Lösung dazu? Habe das gleiche Problem, dass die Artielübersicht nicht aufgerufen werden kann.

    Artikel lassen sich anlegen und auch über die Suche im Backend öffnen.

    Danke für einen Hinweis :-)

    Gruss

    Michael
  • davididcdavididc MemberComments: 15 Received thanks: 4 Member since: October 2014
    Hallo Zusammen,

    gleiches Problem hier :-(

    Ist eine Lösung bekannt?

    EDIT: Bei mir lag es an veralteten Template-Variablen
Sign In or Register to comment.