Shopware()->Application() is deprecated

Liebes Forum :slight_smile: :slight_smile:

ich erhalte seit Shopware 5.4.6 ständig Errormails für diverse Seiten in der Art:

Shopware()->Application() is deprecated since version 4.2 and will be removed in 6.0. Use the Container instead. Called by /var/www/vhosts/meinshop.de/httpdocs/custom/plugins/MbdusArticleOrder/SearchBundle/CriteriaRequestHandler.php:65
2019-08-04T08:39:14.100868+0200
core
{
    “uri”: “/cloth/layers/”,
    “method”: “GET”,
    “query”: {
        “module”: “frontend”,
        “controller”: “cat”,
        “action”: “index”,
        “sCategory”: “68”,
        “rewriteUrl”: “1”
    },
    “post”:
}
No session data available
1
meinshop

  1. Wie ersetzt man Shopware()->Application() konkret ?

  2. Es ist ja nur deprecated. Darauf aufmerksam gemacht zu werden ist ja ok, aber ständig mit solchen E-Mails ist nicht so ok. Kann man das irgendwie ausschalten ?

Hallo, ich habe das Gefühl, der Post ist über das Wochenende in Vergessenheit geraten. Deswegen nochmal eine kleine Erinnierung :slight_smile: