Responsive Deaktivieren

Hallo,

 

und zwar geht es darum das ich vorerst das Responsive Design gern deaktiveren möchte.
Ist das irgendwie möglich?

Liebe Grüße aus Dresden

Sascha
 

Hallo @Sascha_Zoundhouse‍,

du kannst einfach per Meta-Angabe den Responsive Modus deaktivieren. Alternativ kannst du auch einen Button anbieten und per Javascript / jQuery die Meta-Angabe setzen, was ich präferieren würde:

$(document).ready(function(){
   $('meta[name="viewport"]').prop('content', 'width=1280');
});

Viele Grüße,
Stephan Pohl  Shopware

1 Like

Danke dir schon einmal für die schnelle antwort. 
Ich muss nur noch fragen, da ich es erst einmal nicht über Button mache, sondern generell das Respons deakt. möchte und später nachliefern will, in welcher Datei, wo mache ich die angabe? 

 

Liebe Grüße aus Dresden 
Sascha 

Geht das nicht, wenn man ein eigenes Theme erstellt und die header.tpl nach seinen Wünschen anpasst?

Hallo [@Stephan Pohl](http://forum.shopware.com/profile/2/Stephan Pohl „Stephan Pohl“)‍,

wie kann man denn einen solchen Button einbauen?

Viele Grüße, Alex

Hey @Sascha_Zoundhouse‍,

du kannst einfach wie @R4M‍ schon sagte einfach in deinen eigenen Theme die “index/header.tpl” anpassen und entsprechend die Meta-Angabe vom Viewport anpassen.

@a.horst‍ - Im eigenen Theme baust du einen Button an der von dir gewünschten Stelle ein, erstellst dann eine eigene Javascript-Datei und baust einen Event-Listener für diesen Button ein.

Gehen wir davon aus, dass der Button die Klasse “btn–disable-responsive” hat, dann würde der Listener wie folgt aussehen:

$(document).ready(function() {
   $('.btn--disable-responsive').on('click.disable-responsive', function(event) {
      event.preventDefault(); // disables the default behavior of the button
      $('meta[name="viewport"]').prop('content', 'width=1280');
   });
});

Viele Grüße,
Stephan Pohl  Shopware

Ich muss die frage jett leider noch mal aufgreifen, da ich es bisher nicht geschafft habe, Responsive zu deaktivieren.

Ich hab den Viewport so gesetzt:

Leider ohne erfolg.

Responsive bleibt aktive :-/

Ich hab den Viewport so gesetzt:

Hmm, ich sehe leider nix. Eventuell über die Editorfunktion “Codeschnipsel einfügen” gehen.