IFRAME CODE funktioniert nicht auf Shopseiten

Hallo! Hat jmd. eine Lösung/Vorschlag wie ich eine externe Seite als IFrame oder ähnliche Lösung bei mir miteinbinden kann?
Der Iframe Code funktioniert grundsätzlich, aber leider kann ich damit keine fremden Seiten hinzufügen! Ich kann nur eigene Seiten hinzufügen.
Z.B. /kontakt etc. … aber auswärtige Seiten werden nicht geladen.

Es erscheint nur ein weißes Fenster. Ich glaube mein Server erlaubt dies nicht?

Oder liegt es doch an einer versteckten Einstellung in Shopware? Bitte um Unterstützung. Vielen Dank!

Normalerweise möchte man sowas nicht, da es natürlich potentiell Security Issues birgt. Das wird daher per .htaccess ausgeschlossen.

1 Like

@Moritz Naczenski schrieb:

https://github.com/shopware/shopware/blob/5.4/.htaccess#L120

Normalerweise möchte man sowas nicht, da es natürlich potentiell Security Issues birgt. Das wird daher per .htaccess ausgeschlossen.

Das ist nett, danke für die super Hilfe!
Wäre es möglich, dass Sie mir noch mitteilen, wie ich eine einzelne Seite in .htaccess den “Zugriff” erlaube? Vielen Dank! 

Wohl falsch verstanden. Du kannst keine fremde Seite einbinden, wenn DIESE z.B. x-frame-options DENY gesetzt hat. Das hat nichts mit der eigenen htaccess zu tun.

https://developer.mozilla.org/de/docs/Web/HTTP/Headers/X-Frame-Options

 

1 Like

Danke für den Hinweis. Aber ich lasse das mal überprüfen, da die „Fremdseite“ ebenfalls mir gehört. Es ist nur ein andere Projekt - das ich dort gerne zeigen würde. Danke!