Exception during using API: Status = 400 | Detail = This value should not be blank. |

I am integrating JTL-Wawi with Shopware via JTL-Connector. Everything is configured, works pretty smooth but in the middle of syncing products I got this error:

System.Exception: Exception: Controller = Product | Action = push | JTL-Wawi PK = XXX | SKU = XXX | Name = XXXXProductNameXXXX | [ffc77185-420a-43d9-b785-575f4e4825e6] The Shopware 6 Admin API responded with an error:
Code = c1051bb4-d103-4f74-8988-acbcafc7fdc3 | Status = 400 | Detail = This value should not be blank. | Pointer = /0/translations/14f5b20028c64a679488b891af09e84d/customFields/short_description

(some fields are marked by XXX)

And the magic is happened. Some facts:

  • I checked the product in JTL-Wawi and products has a translations for all languages.
  • In Shopware configuration, in Custom Fields sections, I unchecked „Required“ fields for „short_description“.

So content looks good…

I was thinking that maybe json payload has a empty value: „short_description“:„“ - and It was… So in vendor/shopware/core/Framework/Api/Controller/SyncController.php file I used str_replace and replace „short_description“:„“ for „short_description“:„


“ - I know that is a wrong way modify vendor, but I need it to debug. But… didn’t help. The same error.

So my questions are:

  • Can somebody know how to check / debug / fix this issue?
  • Does somebody know how to temporary disable incoming data validation? Just in order to make a full import.

I’m looking forward to hearing from you!

Best regards,