2 stellen nach dem Komma & aufrunden.

Hallo liebe Community,

hab ein kleines Problem, und komme einfach nicht weiter.

 

Wie kann ich einstellen das mir die Zahl mit 2 stellen nach dem Komma gezeigt wird, und das die 3te Stelle die 2te Stelle auf oder abrundet ?

Hallo,

beispielsweise mit der smarty - Tag {$sArticle.price|currency} oder mit dem smarty - Tag {$sArticle.price|number_format:2} .

Grüße

Sebastian

@sschreier schrieb:

Hallo,

beispielsweise mit der smarty - Tag {$sArticle.price|currency} oder mit dem smarty - Tag {$sArticle.price|number_format:2} .

Grüße

Sebastian

klappt super, jedoch 1 kleines Problem.

Überall ist ein Komma  also zb 1200,45 EUR

Aber wenn ich {$sArticle.price|number_format:2} nutze steht da kein Komma mehr sondern ein Punkt also zb. 1200.45 EUR

Wie kann ich das zu nem Komma umändern ? sieht bisschen doof aus wenn überall ein Komma steht nur bei dem Smarty-Tag ein Punkt steht

 

lg

Hallo,

am besten beschäftigst du dich einmal mit den beiden Smarty - Methoden, die ich dir dafür genannt habe, dann würdest du sehen, das gerade die zweite Methode noch weitere mögliche Parameter hat, die gerade deinen Zweck erfüllen würden: Smarty :: View topic - number_format modifier, maybe can help out someone . Double wird nunmal als Punkt gespeichert, deswegen ist es auch logisch, dass da ohne weitere Parameter ein Punkt als Trennzeichen kommt.

Grüße

Sebastian

1 Like

@sschreier schrieb:

Hallo,

am besten beschäftigst du dich einmal mit den beiden Smarty - Methoden, die ich dir dafür genannt habe, dann würdest du sehen, das gerade die zweite Methode noch weitere mögliche Parameter hat, die gerade deinen Zweck erfüllen würden: https://www.smarty.net/forums/viewtopic.php?p=39057 . Double wird nunmal als Punkt gespeichert, deswegen ist es auch logisch, dass da ohne weitere Parameter ein Punkt als Trennzeichen kommt.

Grüße

Sebastian

also so wie ich es verstanden habe müsste es so korrekt sein.
{$sAmount|number_format:2:".":","}

Leider ist das Trennzeichen immer noch ein „.“ und kein „,“

 

:confused:

keiner ne lösung für mich da :frowning:

@SB schrieb:

Steht doch oben.

Leider klappt es aber nicht, ich hab mich damit beschäftigt und bei mir sieht es so aus:
{$sAmount|number_format:2:".":","}

Aber es kommt einfach kein “,” sondern ein “.”

Hallo,

ist das jetzt dein ernst? Die Syntax (wie oben im Link ausführlich beschrieben ist ja): String, Dezimalstellen, Dezimaltrennzeichen, Tausendertrennzeichen.

Bei deinem Code ( {$sAmount|number_format:2:".":","} ) müsste also 1,200.45 € rauskommen, was es ja auch tut. Es ist also doch alles korrekt. Wenn du 1.200,45 € ausgeben lassen möchtest, müsstest du logischerweise {$sAmount|number_format:2:",":"."} nutzen, bei 1200,45 € wäre es {$sAmount|number_format:2:",":""} .

Grüße

Sebastian

1 Like