robertoroberto MemberComments: 37 Received thanks: 1 Member since: April 2017

Hi,

I have found this issue and don't know how to resolve it. In my product there are some extra fields added using this free text fields functionaly. They seems to work when you land in the product but once you select a diferent variant, for example default is 'black' and you select 'white' the value is set to null which is a problem for me.

Is this a bug in shopware? Am I doing something wrong?

Hope you can help me

Thanks

1 Answer

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7214 Received thanks: 2139 Member since: September 2013

    There is a button in the variant configuration where you can apply basic information of the main variant to all other variants.

    Quote
    Accepted Answer
  • Accepted Answer

Answers

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7214 Received thanks: 2139 Member since: September 2013

    The attributes / free text fields are different for each variant, so you need to add your data to each variant - it will change to the free text fields of the variant when changing the variant itself.

  • robertoroberto MemberComments: 37 Received thanks: 1 Member since: April 2017

    Thanks I didn't knew that. Is there any way to copy the 'base' configuration to the variants? For some products I have 2000+ so this is something I'd like not to do one by one

  • Moritz NaczenskiMoritz Naczenski AdministratorsComments: 7214 Received thanks: 2139 Member since: September 2013

    There is a button in the variant configuration where you can apply basic information of the main variant to all other variants.

    Quote
    Accepted Answer
  • robertoroberto MemberComments: 37 Received thanks: 1 Member since: April 2017

    Thank you, that did the trick for me :D

Sign In or Register to comment.